Results 1 to 7 of 7
  1. #1

    i think the carbs need a rebuiled

    same shit different day
    last time i got the ski out it ran good till i put it on its side whan i was stuffin around than it ran like crap (would not start for a long time in the middle of the gulf about 1/2 h ) and whan it did go it ran like crap so whan i got it home i put a new fuel filter on it and new plugs and run fine
    so yesterday we went down and it ran fine for about 45mins and started to play up but this time it would start and idle fine as soon as you would throtte it would run like crap for a bit than come fine till next time you took it down to idle so in sort you would have to play with the throttle till it come good so dose anyone know what would fix this do i have to do the carbs or is there something else i could be doing


  2. #2
    Carbs are always on the neglected list! When was the last time you had them apart for inspection/cleaning?

  3. #3
    Quote Originally Posted by ZMANN View Post
    Carbs are always on the neglected list! When was the last time you had them apart for inspection/cleaning?

    yeah about that lol
    um never and i doute they have ever been apart

  4. #4
    lol! what ski?

  5. #5
    Quote Originally Posted by ZMANN View Post
    lol! what ski?

    shes a waveblaster 2 760 and only mod is a ride plate

  6. #6
    Have you ever done carbs before ? there are some good how to rebuild links if you need

  7. #7
    Quote Originally Posted by ZMANN View Post
    Have you ever done carbs before ? there are some good how to rebuild links if you need

    nar ive never had tham done ill try and find the rebuild links

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 10
    Last Post: 07-06-2015, 12:38 PM
  2. Replies: 2
    Last Post: 07-14-2012, 09:37 PM
  3. Replies: 2
    Last Post: 08-06-2008, 08:04 AM
  4. No Fuel to the carbs! Newb needs help!
    By sweetcoupe in forum Polaris Open Discussion
    Replies: 19
    Last Post: 01-30-2007, 01:26 AM
  5. New Color Scheme for for the RXP Need Opinions!!!
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 45
    Last Post: 10-09-2005, 04:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •