Results 1 to 8 of 8

Thread: High Idle?

  1. #1
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032

    High Idle?

    I just got my ski back from the dealer cause I had some MAINT and SENSOR issues I could not fix myself and he told me the idle was too high @2300 on my 07 RXT instead of 1800. I have not touched the idle screw or any of that. I did not reallly realize it was high until he told me but I did notice that it was faster at idle because I could outrun ATC2006's RXT in a no wake zone. I noticed this increase after I did the waterbox mod and j-pipe flare. My dealer said he had seen this on 3 other RXT's but did not know what their mods were. Has any RXT owner see this on their ski or any comments??


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Larry, check the adjustment on your throttle cable. It sounds like it may not be releasing completely.

    There should be a slight amount of slack in the cable at the throttle body when the throttle is released.

  3. #3
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    This happened to me when I forgot to plug in the exhaust temperature sensor once. Since you messed with the exhaust, I wouldn't rule out the idea that yours is unplugged (unless you already checked it). If everything else is good then go with what Jerry said about the throttle cable adjustment.
    Last edited by Green Hulk; 10-30-2007 at 04:28 PM.

  4. #4
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Thanks! I'll double check that...I did adjust by throttle cable lately but it looks like it's hitting the stop screw...I think I will readjust and add some more slack...

  5. #5
    I read somewhere on here that if the throttle body isn't sealed completely to the intake manifold.....it will idle high.....I've removed many throttle body's and never had this problem..... just putting it out there if you've ever romoved it

  6. #6

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    Your I.a.c. Motor Could Be Sticking.todd

  7. #7
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by Turbo Todd View Post
    Your I.a.c. Motor Could Be Sticking.todd
    Run that by me one more time??

  8. #8

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    Thanks For The Phone Call Larry And I Will Bring The 82 And 83 Rings With Me. "i Love To Test It Is So Much Fun" Todd

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 GTX High Idle
    By Brad in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-11-2008, 12:28 PM
  2. Why the high idle??
    By addicted in forum 4-Tec Performance
    Replies: 22
    Last Post: 03-17-2008, 07:30 AM
  3. Very High Idle SL 750
    By doogrich in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-14-2007, 05:16 PM
  4. HIgh Idle on 07' RXP???
    By NJRXP in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-18-2007, 12:10 PM
  5. 04 rxp 'sensor' /high idle/trim gauge
    By cdooRXPxtrm in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-17-2006, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •