Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40
  1. #1
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3

    Who has an RXT with RR ECU?

    1. What are your idle rpms when the ski it out of the water and on a trailer...

    2. What prop and pitch are you running, and what are your RPMs and speeds at WOT...

    truthfully don't know many of anyone that currently run an RXT with an ECU, or if they do they do not post often and say what they are running. Hoping someone out there with this setup speaks up

    in water i idle at 1800-1900.... on the trailer i idle at 3000 rpms

    i cannot get my rpms above 7900-7950.... i've tried 14/18.5 and a 15/20, and i bent the trailing edges of my 15/20 quite noticeably and saw no rpm change. I just suck at bending props

    Next i'm putting the stock prop on with the biggest venturi ring I have to see if i can get anywhere close to 8400

    2005 RXT currently running 71.9 @ 7900 rpms


  2. #2
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,678
    +1
    3
    Shibby... my ECU is at the post office. I'll pick it up at 2:00 and try like heck to have some results today... it most likely will be tomorrow though.

    I have a Solas 14/18.5 and five Stockers (12/18, 18.5, 19, 19.5, 20), hopefully one of them will work out

    Jeff

  3. #3
    CRS's Avatar
    Join Date
    Jul 2005
    Location
    Auckland, NewZealand
    Posts
    335
    Shibby,
    you`ve got Les` b kit also don`t you. If you do your gonna need bigger injectors!

    Chris.

  4. #4
    Sunfunzoom's Avatar
    Join Date
    Apr 2005
    Location
    Near Detroit Michigan
    Posts
    141
    You may have to go to the dealer and do a TPS sensor adjustment with BUDDS
    If you replace the ECU, that may have to be done.
    It would explain your high idle and lack of RPMS

  5. #5
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    i am my dealer

    TPS on BUDs is perfect.... in the water it idles perfectly, out of the water it idles very high at 3000

    no B kit... it was just for shits and giggles for a week or two that i borrowed from a forum member...

    ONLY mods are:
    external Intercooler
    RR ECU
    Thru-hull exhaust
    4" intake
    Solas
    NOPAS
    Wedge

    71.9 @ 7900

    have tried 14/18.5 and 15/20 and repitched 15/20 with a 81mm nozzle .... all 3 props/pitches yielded identical RPMS but with different speeds

  6. #6
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    Quote Originally Posted by Shibby1485
    i am my dealer

    TPS on BUDs is perfect.... in the water it idles perfectly, out of the water it idles very high at 3000
    typically a symptom of a vacuum leak

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    would that cause it to idle perfect IN the water tho?

    here's how it goes.... i NEVER touched the intake manifold from the factory, stock intercooler, plumbing, nothing.... everything was stock and i added RR ECU and it idled at 3000 on trailer.... put it in water, i idled fine...

    then i take it out, remove the stock intercooler, ultra-black block off plate, and clamped all the couplers for pipes... added RR ECU and still 3000 out of water but 1800 IN water...

    BUT... it does not do this with the stock ECU... only does it with the RR ECU


    i tell you one thing i do hate about Rotax Racing... no one knows chit!! no offense to anyone at all... but these ECUs every single time are issues. it takes MONTHS to work out small issues people have. like last year every stage 1 RXP was seemingly stuck at 7600 rpms all i get is... "musta been an install error, must be a leak, must be this".... everything is checked over, everything works dead perfect when in stock form and with an air intake and exhaust, and everything has been installed with a top notch mechanic by my side that has installed all the same parts on skis all last season.... this ECU is nothing but problems and BS and i'm about to sell it or throw it in the ocean and go with a complete Riva kit and never look at Rotax again.... i'm not gonna call PPG for tech help, and Mark is the only other soource and he's a busy guy and not one guy can have all the answers to every problem i don't think...

    i find it VERY hard to believe that my problem lies in the pump... i tried 3 different pitch props, and i saw no RPM change... does that mean anything to anyone??????? does that not raise a few questions?


    freaken pay 300 bucks to some guy on other side of the world to reflash ECUs, and we can't even get in touch with the guy and ask some questions about his product and reprograms and ask for tech help for his expensive items...

    am i a bit heated? absolutely..... JEFF!! you about all I got to compare with, don't let me down

  8. #8
    nothing like being on the forefront Shibbs! I'd put the stock ECU back on relax a bit with your ski and see if Jeff runs into the same problem.

    Did you change your spark plugs ?




















    HAHA j/k
    Dude your breaking 70. It could be worse. Can't wait till you get it tuned and post about your 75 mph break.

  9. #9
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    lol... yea got iridium plugs in there with 5 hours

    right now i'm thinking gettin home thursday and tearing it apart and starting over i think. Go back to stock and piece it together. Gonna be a long weekend with this pile o junk...

    all the GPR guys are starting to convert to RXPs, and i'm about to sell this sack o chit for a GPR myself

  10. #10
    Can you not just get it going with the stock ECU ? Then when the 3 blade comes out try to get it tweaked up for the New RR ECU. By then the bugs might be worked out.

    ....Shibby I need you......
    don't leave me now
    The RXT modders are thin as it is

    maybe not I'll just give you a beer and let you drink it off

    go stock ECU, goooo stock ECU then RR laterrrrrrrr after the bugggssss are gonnnnneeee
    ^^ my subliminal message while you are durnk

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. who is running a riva b1 wheel with the ecu reprogramming?
    By gordon lasiter #328 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 04-02-2010, 06:11 PM
  2. Who here is running an RXT with open loop cooling?
    By Green Hulk in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-05-2009, 07:10 PM
  3. Who Has & Is Good With Photoshop
    By Flynfox in forum Open Discussion
    Replies: 38
    Last Post: 09-05-2007, 12:19 AM
  4. Who has a 1390 Triple piped with I bodies?
    By OutlawGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-26-2007, 11:28 PM
  5. Riva stage 1 who has it? on the RXT
    By 2006 RXT in forum 4-Tec Performance
    Replies: 12
    Last Post: 04-13-2007, 01:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •