Results 1 to 6 of 6
  1. #1

    Join Date
    Jun 2005
    Location
    Singapore
    Posts
    2

    2004 RXP - "MAINT" flashes on Dashboard

    I bought a RXP in September 2004 and now have clocked 56 hours on it. Whenever I put on the lanyard, it flashes "MAINT" before going on to the actual screen, which I have preset to RPM mode.

    I was told by the dealer to press the SET button five times or for five seconds and it should go away permanently. I tried both methods, but all I see on the display after I press SET five times is "END". No error codes are displayed while pressing the SET button.

    I was actually expecting to see the "MAINT" display on the screen at 100 hours. Any cause for concern? Any other RXP owners experience the same thing?

    What would happen if I ignore the "MAINT" on the dashboard?

    Thanks in Advance...


  2. #2
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,278
    +1
    2
    How does the ski run? Does it run like its got the learning key on?

    Another question, is it a salt water ski?

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,983
    +1
    1,900
    the maint light flashed to remind you to take it to the dealer for service.

    if your dealer is telling you to push set 5 times to make the screen go away you may want to find another dealer

    the only way to clear the maint light is to have the dealer turn it off using the BUDS software.

    There is no problem with simply ignoring the maint screen

  4. #4
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,278
    +1
    2
    The reason I asked the question how it was running is because my friend has a 2001 rxdi that he runs mostly in salt water. Well one day the maintenance light starts flashing and the thing goes into limp mode, like its got the learning key on. Well to make a long story short, he had been riding in the salt long enough to where the tips on the plug wires where they meet the plug , had built up a light coating of corrosion! I found this out by taking the plugs off and cleaning them with a rag. After that, BAM!!!!!!!!! The ski ran like a champ, no more maintenance code flashing anfd ski was at full power again! Simple things like that are what ive learned over and over in the last 3.5 years of riding in salt! That crap sucks if you dont clean em up the RIGHT way!

  5. #5

    Join Date
    Jun 2005
    Location
    Singapore
    Posts
    2
    Hi,

    The ski actually runs perfect. No problems whatsoever. I get between 69 and 70 miles on flat water.

    And yes, it is a salt water ski. Better yet, the water in Singapore is quite polluted in some areas. By polluted, I mean debris like wood planks, plastic bags and even oil spills. But we usually find a way around that. No one has has ever suffered any damage to their ski's due to polluted water except for sucking up the occasional plastic bag.

    I spoke to the dealer and he said that he needs to come by with the software to erase the "MAINT" light. It's still under warranty so I guess I don't have to pay for anything. Just wondering what to do if it flashes again after a couple of hours of usage.

    I'm just curious how different RXP's flash the "MAINT" light at different hours. I even read one RXP having the "MAINT" light come on at 85 hours. Do the electronics and sensors actually guage the hours of usage or actual mileage?

  6. #6
    brad2510's Avatar
    Join Date
    Aug 2005
    Location
    Jacksonville, FL
    Posts
    595
    My Maintenance light came on at 100 hours.

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. 2004 RXP Paint Codes
    By Thomas in forum Sea Doo How To & FAQs
    Replies: 5
    Last Post: 07-23-2007, 12:14 AM
  2. 2004 RXP...Dissapointed
    By Teddy57 in forum 4-Tec Performance
    Replies: 31
    Last Post: 07-22-2006, 01:40 PM
  3. HELP!! my 2004 rxp had low the RPM's at full throttle
    By rafyrxp in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 06-17-2006, 11:46 AM
  4. 2004 RXP vs. 2005 RXP
    By Teddy57 in forum 4-Tec Performance
    Replies: 14
    Last Post: 12-03-2005, 03:54 PM
  5. This can't be right... 2004 rxp with 5 hours for $3K
    By Enufpwr in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-25-2005, 09:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •