Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Nitro, HELP on my f12x

    Hi Shawn, need your help on my f12x. its giving the FI warning and when i check for what code it gives me it give 10 beeps and 11 beeps which is not on the service manual. when i reset it and test on the water it does the same thing. after maybe 10seconds of full throttle operation is gives the buzz again and the FI warning beeping. it cuts the engine to 3500 rpm. and when i turn the engine off and wait for the meter to shut down and start again it runs good again. by the way if i maintain the rpm at 4000-4500 rpm and use the ski it runs perfect for good. its just when i hit full throttle for 10 seconds it gives the warning. What do you think is the problem on this ski. i have a 2004 f12x. Thanks Shawn.


  2. #2
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    1) check the IAT sensor, Is it between 1-4 Ohmns? Do you have + 5V at the gray feed wire?

    2) If OK. Unplug the Knock sensor and see what happens, if anything.

    3) Also do the test here for the WGS.

    4) After that, hook a boost gage and read what it says.

    sg

  3. #3
    ok Nitro, will do that and I will let you know ASAP. Thank you so much.

  4. #4
    by the way Nitro, what psi should i expect to look for with the boost gauge to the WGS?

  5. #5
    Nitro, found the problem with my f12x. i got a leaking wastegate actuator coz its corroded already and there is already a hole in the metal iaphragm in the actuator.

    My friend has a f12x also and needs help. He changed the ecu, throttle body and ect sensor as well. coz it sows the warning and beeps 7 and 8 which corresponds to ect and tp sensor. now he installed the new ect sensor and the throttle body and the ecm. and still the FI showed up again. when we diagnosed the ski it gave the 7 and 8 beeps again with the new items. we tried to switch wire harness with a good running f12x and stll gave that FI warning with 7 and 8 beeps. what do you think is the problem on this ski there seem to be no answer to it based on the service manual. Anybody ever had this kind of problem before? Any help would be very much appreciated. Thank you.

  6. #6
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    Quote Originally Posted by timmy_philson View Post
    Nitro, found the problem with my f12x. i got a leaking wastegate actuator coz its corroded already and there is already a hole in the metal iaphragm in the actuator.
    The stock actuator has a little hole in it stock. (near the bottom of it)

    To check it for proper operation:

    1) Put 8 psi of air to the actuator inlet. The valve rod should start to move.

    2) Next, Put 13 PSI and the rod should move further about 3/8 inch total.


    Tell your Friend to test his TP sensor. per the service manual. Should have about .38-.6V at idle and 4.2-5V at WOT


    Sg

  7. #7
    Nitro, The actuator didnt moved. i am using a pop off gauge and even reached upto 20 psi. i tried it on a subaru turbo and the rod moved at 8 psi and even more as the pressure gets higher. i tried it on my friends f12x and the rod moved at 8psi also. but the arm where the actuator rod is connected wont move. maybe the wastegate valve inside the turbo is having a hard time to move also. i checked my turbo, dismantled the other side and saw the valve inside the turbo. and it was stuck so i had to lubricate it and move it close open. maybe i have a faulty actuator and do you think there is a relevance to the 7 and 8 beeps on my friends f12 with the arm not moving but the actuator rod moving? i will try to clean and lubricate the arm of my friends f12x and check what will happen. do you have any similar experience as i have?

  8. #8
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    The pivot on the arm is common to corrode this must be kept lubricated on all Honda's, The waste gate valve inside the turbine house also will stick, and be sure to check it.

    Check your diaphragm separately now if you can.

  9. #9
    Nitro, I pulled down my turbo right now and opened the turbo and saw the valve inside which the actuator opens. its kinda sticky and did some cleaning of carbons and lubricated the arm and now its kinda better when you play the arm with your hand. the actuator il try to lubricate thru the hole on the actuator and see if there will be any difference.

    What diaphragm are you referring to open? the actuator? how do i open it?

  10. #10
    Nitro, I tried to bowwor my friends turbo set and cleaned the valve also coz when i checked it its kinda sticky already too. As of now its running good. no more warning and FI warning. Gues its just the wastegate actuator that i have to replace. i cleaned my turbo already and just finding out ways how to open the actuator.

    As for my friend what else do you think would be the possible problem for his ski giving that 7 and 8 beeps even if he already placed brand new ecu, tp sensor, throttle body, iat sensor, and ect sensor. that warning light still goes up and gives 7 and 8 beeps. and cuts the engine to 3000 rpm. do you think there is something wrong inside the engine or cooling in the block?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. i need help on my gprxp
    By raul466 in forum Conversion PWC Performance Skis
    Replies: 1
    Last Post: 07-23-2009, 08:38 AM
  2. More help on my GPR....Now intermittent starting!
    By ramairformula74 in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 07-17-2009, 09:30 AM
  3. need help on my 550sx - 650sx conversion!!
    By PeteSkeet in forum Conversion FAQ and Tips
    Replies: 0
    Last Post: 05-01-2009, 09:36 PM
  4. f1 light on my f12x please help
    By turbina salad in forum Honda Performance
    Replies: 3
    Last Post: 05-01-2009, 08:44 PM
  5. HELP wite my f12x -02 knock sensor problem
    By audirs2 in forum Honda Open Discussion
    Replies: 4
    Last Post: 08-17-2007, 07:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •