Results 1 to 2 of 2
  1. #1
    mad about machines
    Join Date
    Nov 2007
    New Zealand

    Unhappy ZXI 900 shudder at low speed??

    I noticed that my ski has a noticable shudder at low revs, it also seems that the impeller is slipping a bit when accelerating, much like a clutch slipping in a car. Could both of these be due to an impeller issue??
    I am new to this game so am trying to figure it myself as I dont have oodles of cash to throw at someone to fix it if i could do it myself.
    Is it a big problem or not??
    Any help??
    Last edited by jaminjarmin; 11-14-2007 at 03:07 PM. Reason: need help

  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Southeast Ohio
    The vibration is normal. Take a peek at your impeller, the "slipping" is probably due to cavitation. I bet the edge of the impeller is roughed up a bit.

    Take pictures and post them if you can.

    Let us know what you find.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New guy needs help with fuel lines...please
    By jdauntless007 in forum Polaris How To & FAQs
    Replies: 17
    Last Post: 05-15-2013, 01:40 PM
  2. Please help with pre-purchase advice, Updated with pictures
    By Fink in forum Polaris Open Discussion
    Replies: 52
    Last Post: 04-16-2013, 07:11 PM
  3. Please recommend Dealer to help with international purchase
    By 4stroker85 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 12-20-2010, 08:46 PM
  4. Help with engine question please!
    By aleblue in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 03-10-2007, 12:03 PM
  5. Help with intercooler strainer please
    By Turbo Todd in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-26-2006, 08:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts