Results 1 to 5 of 5
  1. #1

    02 Genesis i won't run need help.

    I have a 2002 Polaris Genesis i 1200cc with ficht injection. I have been working on it for two weeks strait and need some fresh ideas of what to do next. This is where I'm at. The ski has only 25 hours on it. I have spark, air, and fuel. It cranks fine. I drained and changed the fuel with fresh fuel. I cleaned all injectors and checked to make sure the solenoids were solenoiding. One cylinder has low pressure at 60PSI. But I still think it should run. I'm leaning towards low fuel presure not misting do to back fires during starting and instant wet black spark plugs. Any thoughts and does any one know what pressure ficht injection requires? Thanks so much!
    Mike


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Mike, disconnect the TPS and see if it wil start.

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Oh and WELCOME to the Green Hulk!!!

  4. #4

    TPS disconnected

    I disconnected the TPS but still no start. Random backfire as before and it would grunt a little like it's going to go but nothing. Any more test you can think of? Thanks for the welcome to Green Hulk.
    Mike

  5. #5
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Sure.

    Common misfires are batteries and statot but I doubt the stator would be bad unless it was under water or something of that nature (assuming the hours are that low).
    Even though it cranks good it may still be too weak to fire the PVL ignition system.
    Get a jumper pack and try that or make SURE the battery is fully charged. You need 10.5 plus volts at the battery during cranking.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 Virage still won't run!
    By Rachel in forum Polaris Open Discussion
    Replies: 18
    Last Post: 08-07-2012, 12:43 PM
  2. won't start need help
    By jamey2466 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 08-20-2010, 01:59 PM
  3. 2002 Genesis I with No Spark - Need Help
    By Jeffa15 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-01-2010, 02:10 PM
  4. 2004 Genesis I Won't Run...
    By JJL1968 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-23-2010, 06:49 PM
  5. '02 Virage 800i fuel injection questions... need HELP!
    By ProXR 440 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 06-17-2009, 01:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •