Results 1 to 3 of 3

Thread: Stator problem

  1. #1

    Stator problem

    I have a 2002 Polaris Genisis i 1200. I had it running yesterday and it just shut off and would not start back up. I checked fuel injectors and there not firing. Low voltage to the injectors. My question is what steps up the voltage from 12v to 22v or even 45v while running? Is it the stator only or should I also be checking something else. Battery is good. And so are connections. What role does the Capacitor play?

  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    How did you verify the injectors are not firing?
    What's the fuel pressure within your system?

  3. #3
    axgrider73's Avatar
    Join Date
    Feb 2007
    Southeast Ohio
    There is a manual for this ski in the Tech Section. It might be worth checking out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1986 JS 300 Stator problem
    By chazdo2 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 11-17-2008, 08:58 AM
  2. Stator Problem
    By strmchzr in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 09-16-2008, 12:52 PM
  3. Stator Problem Need Help!!
    By joub6708 in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 07-23-2008, 08:52 PM
  4. SL 650 Stator Problem
    By Travisg75 in forum Polaris PWC Performance
    Replies: 6
    Last Post: 07-23-2008, 05:30 PM
  5. 96 Cane, dry piped, stator problems
    By jm43654 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-20-2007, 03:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts