Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128

    Question Riva valvespring swap - help??

    Trying to do the valvespring swap ... I pressurize the cylinder to about 80 psi, I can hear and feel some air leaking out of the exhaust manifold bell (J pipe is off). Then when I start to crank down the Riva tool, as soon as I crank down the spring, I get air rushing out the exhaust (or intake depending on which valve I try), and the valve does not seem to stay up, it just continues to drop as I compress the spring. ??? Am I doing something wrong?? Are all my valves shot at 150 hrs? As soon as I compress the spring, all the air pressure in the cylinder does not seem to hold the valve up, it seems to push past the valve, not keeping the valve up. Help?? Is possibly the air pressure too high, or??


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Vern, put a socket over the retainer and gently tap it with a hammer a couple of times. Then try to crank down on the Riva tool.

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    by the way, i normally use around 120 PSI when i change the valves out.

  4. #4
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,062
    +1
    790
    Vern you will have some loss of pressure. I kept the air compressor at 120 p.s.i. and when it dropped bellow it. It would turn on automatically. IT NEEDS to or ....

    Also Jerry has you covered. All that is happening is your retainer is in its seat real good and a little tap with the socket will free it and you will be ok.
    Also for safty and piece of mind. Put some rags in areas so as to catch any retainers you may drop. People have done it and I did too, but I had rags to catch them.
    .

  5. #5
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    Quote Originally Posted by Green Hulk View Post
    by the way, i normally use around 120 PSI when i change the valves out.
    forget to change the regulator, huh?.....just kidding(sorta)

  6. #6
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Wow, 10 minutes and tons of help Thanks guys, I really appreciate it! I will tap them to loosen up the retainers and locks.

    120 psi ... NOW ya tell me ... too funny ... the damn Riva instructions say 80 psi MAX!!! So, no ****, I spent 20 minutes adjusting the high and low setpoints on the compressor FROM 100 lo - 120 high, to 70 low, 80 high ... Jeepers ... OK, back to the barn and crank the PSI back up and tap those dang springs! Thanks again!

  7. #7

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    DANG JERRY I DIDNOT KNOW THAT TOOL COULD CHANGE OUT THE VALVES WITH THE HEAD ON. I HAD TO DO IT. I HOPE NO LOVE LOST MY FRIEND

  8. #8
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,062
    +1
    790
    Vern Just FYI, You may here the motor cylce and a piston moves down. The chain will move also. All is ok, don't freak out.

    .

  9. #9
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Thanks Austin, appreciate that. And I DID stuff tin foil in/on the oil drain holes too, then put cloth on top of that ... I am NOT taking any chances!

  10. #10

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva REar intake help
    By miamirider in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-14-2007, 09:58 PM
  2. supercharger washer swap help
    By mjet in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-03-2007, 08:09 AM
  3. 05 Rxp Riva Stage 3 Help Guys!!!
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 15
    Last Post: 03-06-2007, 11:02 PM
  4. Lost RPM after installing RIVA Power Filter...help!
    By RXP-REX in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-29-2006, 06:39 PM
  5. Replies: 1
    Last Post: 05-18-2005, 07:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •