Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1

    Generic Fuel Delivery issue--What am I missing????

    Just throwing it out there to see what I ve missed.

    I have a generic 2 cylinder, 750 CC 2stroke engine with a Keihin CDK II that will start and run fine with fuel being dripped into the carb.

    It will start with the choke all the way closed, but then stop as the choke is being taken off

    So First thoughts:

    New Plugs--Have spark

    1) Fuel Delivery--Dirty Carb--Rebuilt the carb
    2) Fuel delivery, dirty lines--replaced all fuel lines
    3) Fuel Delivery--Dirty Selcetor Valve--Cleaned and Lubricated
    4)Fuel Delivery--Pulse line clogged--Next to be replaced--Any way to check this? The fuel pump (built into the CDK II) does not seem to be pushing fuel

    Things I have not done://Reason

    Check Compression --It runs with Fuel, no missing or backfires
    Check Reeds-
    It runs with Fuel, no missing or backfires



  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Good start. I'd certainly replace the pulse line as it can be full of garbage and not get a pulse to the pump. Did you verify no tears or rips in the diaghram and did you check the lines dropping down into the fuel tank?

    I will usually just get a vacuum pump, attach it to the supply line and see if you can draw fuel, if not, you know your leak is from that hose somewhere back to the tank. Verify the fuel valve (if equiped is good or by-pass for testing) and remember it takes a moment for the fuel to pump its way from the tank to the carbs.

  3. #3
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    After you verify your getting fuel,Next would be going thru the carbs.Untreated fuel left in carbs have a tendence to evaporate and gel jets.Is this a oil injected motor or premix?

  4. #4
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    I know that this is a long shot, but it may be worth the time to do a compression check if the other things mentioned above check out. If there is no compression on the cylinder that the pulse line is connected to then there will be no pulse.

    Most engines will run (some quite well) on two cylinders out of the water.

    Just a thought.

  5. #5
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Always good to do one and keep it for record,You'll know then if your getting some wear,etc. Is this in a ski? What year and model?

  6. #6
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    Bad me, i know, but you cannot get info anywhere else.

    This is my 92 Kawi 750 (since its not an ultra, they wont even reply to a post)

    2 Cylinders
    1 CDKII carb
    Oil injected (until my block off gets here)- I can see oil flowing into the manifold
    Clean freshly rebuild carb
    new fuel line ( I have not opened the fule tank and replaced and cleaned all of that yet, so I will do that next)

  7. #7
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    When you can only run with the choke on, then your running a lean condition. Are you sure that there isn't a plugged jet or passage way in the carb?

  8. #8
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    not that I can find. I took it all the way apart and blew through everything I could find

  9. #9

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    hey sean that isnt my carb i sent out to ya is it ?

    if it is than damn that thing is screwy , first off it was the only carb i seen that had a rusted screw and a torn diagharm and was makeing that bank run rich !

    lemme know if you thats the one i sent and if you cant get it to run ill send ya another one but the accelerator pump is jacked


    thats a shame there not paying attention to ya , its almost the same here but with the newer ones not the older ones, im not sure but you might wanna do some research an see if that motor came in a stand up if thats the case just shoot over to addiction.com
    Last edited by Bone1050; 11-28-2007 at 03:03 PM.

  10. #10
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    The thing is we can only work with the info someone gives us,Have you checked everything listed so far?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. STX 12F what am I missing? No fuel. Please help
    By Anacapaboater in forum Kawasaki How To & FAQs
    Replies: 9
    Last Post: 08-13-2016, 11:13 AM
  2. What am i missing :??? 70.2 gps
    By kkgregs in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 04-24-2007, 11:34 PM
  3. What am I missing?
    By qbzonk in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 04-22-2007, 02:08 PM
  4. What am I missing??
    By porksword in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 03-08-2007, 11:20 AM
  5. eBay Scam? What am I missing?
    By WAMason in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-30-2006, 08:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •