Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    Student of Speed rxpwhistler1's Avatar
    Join Date
    Nov 2007
    Location
    Oakland County Michigan
    Posts
    708

    test your knowledge, need some guess/answers

    I forgot to ask this as I just winterized my RXP. This summer I noticed when I take any degree of a sharper turn and try to give it gas, it boggs. It feels like it loses power for a second, than after a few seconds with it headed straight, it performs normal. Anybody have any guesses?


    Thank a lot fellas. I need to wrap this issue up asap so I can add my mods before mudbug..


  2. #2
    CC Racer kenshin89's Avatar
    Join Date
    May 2005
    Location
    VA
    Posts
    2,902
    +1
    2
    I had the same sort of problem with a friend's rxp that I borrowed to race in Amatuer Open at the world finals this past year. We had switched out the 4" air intake to the riva 3" because we were sure if the type of air filter we had was legal. While out practicing everytime you would go into a sharp or even a barely sharp left hand turn the ski would lose power and it felt like it had dropped a cylinder.

    Finally we just said F it and put the 4" air intake back in and problem solved lol. Kind of sucks we spent like 3 days tryin to figure out what was wrong.

  3. #3
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,625
    +1
    806
    Could be a faulty TOPS?

  4. #4
    The ski's have taken a "backseat" to the Corvette DarthAWM's Avatar
    Join Date
    Nov 2007
    Location
    Odessa, TX
    Posts
    5,364
    I think his flux capacitor needs a new beryillium sphere

  5. #5
    My new toys at work bruinsrme's Avatar
    Join Date
    Jul 2007
    Location
    Worcester MA
    Posts
    1,706
    Quote Originally Posted by DarthAWM View Post
    I think his flux capacitor needs a new beryillium sphere
    do you mean that 1 cm beryillium ball with 2 tantilum wires built in spinning at 3600rps in an electrostatic field?

  6. #6
    The ski's have taken a "backseat" to the Corvette DarthAWM's Avatar
    Join Date
    Nov 2007
    Location
    Odessa, TX
    Posts
    5,364
    Quote Originally Posted by bruinsrme View Post
    do you mean that 1 cm beryillium ball with 2 tantilum wires built in spinning at 3600rps in an electrostatic field?
    Possibly, if that doesn't fix it, he should replace the flubber isolator boot.

  7. #7
    bron1c's Avatar
    Join Date
    Aug 2007
    Location
    Guilderland, New York
    Posts
    492
    could a steering cable be pinching some thing when you turn the handle bars?

  8. #8
    Student of Speed rxpwhistler1's Avatar
    Join Date
    Nov 2007
    Location
    Oakland County Michigan
    Posts
    708
    Flubber isolator boot...nice fellas. I appreciate such great advice.

  9. #9
    Student of Speed rxpwhistler1's Avatar
    Join Date
    Nov 2007
    Location
    Oakland County Michigan
    Posts
    708
    Oh and the intake and filter are both stock, so I don't see how that could be causing the turn power loss problem.

  10. #10

    Join Date
    Feb 2006
    Location
    Birmingham AL
    Posts
    2,924
    +1
    2
    BLA BLA BLA I just need more casino cash sorry but free bump up anyway....

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need some quick answers before purchasing an FZS
    By MikeR in forum Yamaha PWC Performance (4-stroke)
    Replies: 18
    Last Post: 02-06-2011, 08:58 AM
  2. Looking to buy a new yamaha jetski, need some questions answered please
    By skeeterzx225 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-22-2009, 02:34 PM
  3. Need some answer
    By mageri in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-17-2009, 05:28 PM
  4. My Test Results (need some help)
    By JFizzleJR in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-09-2007, 07:05 PM
  5. First test with 2 Intercoolers Need Some Impeller Help!
    By somefun in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-14-2006, 07:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •