Results 1 to 8 of 8

Thread: UMI Handelbars

  1. #1
    brad2510's Avatar
    Join Date
    Aug 2005
    Location
    Jacksonville, FL
    Posts
    595

    UMI Handelbars

    Well I have put the handelbars on and everything looks great. The only thing that has been a problem is that the middle cross bar keeps moving. I rode the first time and thought it was just because they were lose. So I tightened them and went out again. That didn't help they moved again 5 minutes after I was out. Now the bars themselves are scratched pretty bad. Has anyone had this problem? To resolve this I was thinking of counter sinking a screw threw the black connectors into the bars. What do you guys think? Is there any other options that anyone has come up with?


  2. #2
    Legend in my own mind Sirhc7897's Avatar
    Join Date
    Aug 2005
    Location
    Lake Butler, FL.
    Posts
    1,143
    Do you just have the bars or the full UMI setup?

  3. #3
    brad2510's Avatar
    Join Date
    Aug 2005
    Location
    Jacksonville, FL
    Posts
    595
    I have the full UMI setup.

  4. #4
    lawracing's Avatar
    Join Date
    May 2005
    Location
    Smith Mountain Lake, VA
    Posts
    736

    Re: UMI Handelbars

    Quote Originally Posted by brad2510
    Well I have put the handelbars on and everything looks great. The only thing that has been a problem is that the middle cross bar keeps moving. I rode the first time and thought it was just because they were lose. So I tightened them and went out again. That didn't help they moved again 5 minutes after I was out. Now the bars themselves are scratched pretty bad. Has anyone had this problem? To resolve this I was thinking of counter sinking a screw threw the black connectors into the bars. What do you guys think? Is there any other options that anyone has come up with?
    I have not had that issue, did the screws loosen up the second time? If so I would try red loctite.

  5. #5
    Legend in my own mind Sirhc7897's Avatar
    Join Date
    Aug 2005
    Location
    Lake Butler, FL.
    Posts
    1,143
    Yeah that is a strange problem...I beat the piss out of mine and have had no problems either...

  6. #6
    brad2510's Avatar
    Join Date
    Aug 2005
    Location
    Jacksonville, FL
    Posts
    595
    It's not that the screws are coming lose. they are still tight. it's just shifting.

  7. #7
    brad2510's Avatar
    Join Date
    Aug 2005
    Location
    Jacksonville, FL
    Posts
    595
    nobody has any suggestions.

  8. #8
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	nopics_460.gif 
Views:	37 
Size:	41.6 KB 
ID:	3454  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. UMI Finger Throttle on Stock Handlebars
    By 1FastTrespiper in forum Sea Doo How To & FAQs
    Replies: 10
    Last Post: 05-30-2011, 03:49 AM
  2. UMI Steering on RXP
    By Green Hulk in forum 4-Tec Performance
    Replies: 41
    Last Post: 12-09-2006, 07:31 PM
  3. I received my UMI steering system today
    By Green Hulk in forum 4-Tec Performance
    Replies: 23
    Last Post: 10-23-2005, 02:08 PM
  4. UMI steering for RXP
    By Green Hulk in forum 4-Tec Performance
    Replies: 39
    Last Post: 10-10-2005, 02:22 PM
  5. UMI Throttle Trigger
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-18-2005, 08:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •