Results 1 to 5 of 5
  1. #1

    Join Date
    Feb 2006
    Location
    Florida
    Posts
    101

    Problem with wife's ski

    Its a 98 gti and it was popping the 5 amp fuse.its the 2nd one from the bottom. I did find a burnt wire and fuse holder in the rear of the ski that was toast, So I repaired it and found I had a short somewhere. I traced it to be I think the stator. I have pulled the stator, but I do not know how to test it. and if it is the stator will this fix the problem with the 5 amp fuse up front.

    Thanks, yb


  2. #2
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    The 5 amp blows to protect the MPEM,what color was the wire that you found fried ???

    When the 5 amp blows it usually means it has a internal short.

  3. #3

    Join Date
    Feb 2006
    Location
    Florida
    Posts
    101
    Hey Water,
    It was the black ground wire leading to the stator. I believe the stator went bad when the fuse holder in the back fried or the other way around. either way I need a new stator.
    Thanks, yb

  4. #4
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    I have good used stators for the 720,$60 shipped. LMK

  5. #5

    Join Date
    Feb 2006
    Location
    Florida
    Posts
    101
    PM me your address and I'll send you a money order or a cashiers check for it for it. Thanks yb

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Well, I had a big problem with my Ski this Weekend...
    By LiquidDI in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-20-2007, 10:00 PM
  2. OK big problem with the ski
    By mikegpr03 in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 03-26-2007, 06:31 PM
  3. Major Problem with my ski!
    By PMart317 in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 07-08-2006, 11:27 AM
  4. Weird problem with ski this past weekend
    By carbuff91 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 05-20-2006, 06:39 PM
  5. Update on my paperwork problem with the Ski
    By Pettee in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 01-19-2006, 04:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •