Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    08GPR's Avatar
    Join Date
    Nov 2007
    Location
    Sydney, Australia
    Posts
    627

    Intake grate questions

    Hey guys,

    Was out today with the R&D grate fitted. (Stepped stock sponsons) Felt fine at first but after about 30 minutes the ski would porpoise badly and not long after this the ski felt VERY unstable at slower speeds and when I would turn felt as though it was going to tip! So bad that I called it quits until I work out what's goin on. Any ideas?????


  2. #2
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    Did you look for cracks in the grate?

  3. #3
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Almost sounds like you were taking on water.
    Check the installation of your grate maybe a bolt or something has come lose.

  4. #4
    08GPR's Avatar
    Join Date
    Nov 2007
    Location
    Sydney, Australia
    Posts
    627
    Have checked grate. No cracks, bolts are torqued to the correct spec... have included a few pics so maybe someone can pick up something that the untrained eye has missed???
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1198.JPG 
Views:	81 
Size:	748.8 KB 
ID:	46846   Click image for larger version. 

Name:	IMG_1197.JPG 
Views:	59 
Size:	739.2 KB 
ID:	46847   Click image for larger version. 

Name:	IMG_1191.JPG 
Views:	94 
Size:	809.6 KB 
ID:	46854   Click image for larger version. 

Name:	IMG_1192.JPG 
Views:	53 
Size:	603.2 KB 
ID:	46855   Click image for larger version. 

Name:	IMG_1194.JPG 
Views:	61 
Size:	729.7 KB 
ID:	46860  

  5. #5
    08GPR's Avatar
    Join Date
    Nov 2007
    Location
    Sydney, Australia
    Posts
    627
    I was offshore today with a big swell and I've read on the forum that you can take on water through the air inlets. Enough water to notice that much?????

  6. #6
    KamikazeGPR's Avatar
    Join Date
    Mar 2007
    Location
    Philadelphia
    Posts
    1,361
    +1
    99
    I would guess either water in one side of footwell or the famous gpr chine walk at 20-25mph. Does the ski rock from side to side then go away when you hit the throttle?

  7. #7
    08GPR's Avatar
    Join Date
    Nov 2007
    Location
    Sydney, Australia
    Posts
    627
    Yeah, if I went over 50mph it seemed to sort it out but I was'nt keen on hooking into any turns cause of the way it was handling at lower speeds. Thought because first time out with the grate it was that but I'll take it out in the flat tomorrow and see how it goes.

  8. #8
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    How much water did you drain from the engine compartment when you pulled the drain plugs?

  9. #9
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by 08GPR View Post
    Hey guys,

    Was out today with the R&D grate fitted. (Stepped stock sponsons) Felt fine at first but after about 30 minutes the ski would porpoise badly and not long after this the ski felt VERY unstable at slower speeds and when I would turn felt as though it was going to tip! So bad that I called it quits until I work out what's goin on. Any ideas?????
    May just be the "chine walk".

  10. #10
    quadzilla's Avatar
    Join Date
    Apr 2007
    Location
    LOCH NESS Monster-Land
    Posts
    1,178
    +1
    29

    Question Hmmmmmm...??

    Hey There..

    Have a check and make sure that your sponsons are tight..!!!

    It also sounds like maybe you've actually lost a sponson..(admittedly unlikely..but.? )

    Also what where the conditions.. this also sounds like you might be getting one side gunwal loaded with water..??

    Gerry

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. OEM intake grate question
    By GP1300R powerhouse in forum Yamaha PWC Performance (2-stroke)
    Replies: 66
    Last Post: 03-07-2008, 12:13 AM
  2. Aftermarket Intake Grate Question for RXP
    By DooVa in forum 4-Tec Performance
    Replies: 11
    Last Post: 03-21-2007, 07:11 PM
  3. Intake grate question
    By mysilvstang in forum 4-Tec Performance
    Replies: 4
    Last Post: 12-31-2006, 10:07 AM
  4. RXP intake grate question
    By The Bandit in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-31-2006, 07:15 PM
  5. 06 1300 intake grate question
    By rossnemo in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 07-20-2006, 01:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •