Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    1BAD07RXP's Avatar
    Join Date
    Jun 2007
    Location
    Chesapeake Bay, South River, Edgewater, MD
    Posts
    105

    Shorty Waterbox Install

    Im having trouble with the shorty wb it just will not go in. I have untouched j-pipe, shorty w.b., and rude tip. What is the process of doing this. Does the j-pipe stay on the ski or do you install it in one piece. PLEASE HELP its COLD


  2. #2
    I have a trimmed J-pipe but what I did is put the exhaust coupler on the exhaust tip......as far on it as it can go.....put the waterbox in as far back as you can get it towards the rear........get the Jpipe in the waterbox then slide everything toward the eaxhaust manifold ......once you clamp the j-pipe to the exhaust manifold adjust the couplers as needed......tighten it all up

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by cosmicMS3 View Post
    I have a trimmed J-pipe but what I did is put the exhaust coupler on the exhaust tip......as far on it as it can go.....put the waterbox in as far back as you can get it towards the rear........get the Jpipe in the waterbox then slide everything toward the eaxhaust manifold ......once you clamp the j-pipe to the exhaust manifold adjust the couplers as needed......tighten it all up

    perfect explanation

  4. #4
    1BAD07RXP's Avatar
    Join Date
    Jun 2007
    Location
    Chesapeake Bay, South River, Edgewater, MD
    Posts
    105
    Thank you guys to helped alot when I cut the j-pipe 1 and 3/4 now im getting a error code p1544 which I think is a exhaust too high temp so do you guys have any ideas. I checked all the hoses and such and there was a little white smoke coming from my exhaust manifold / jpipe, but it is 43 degrees here. HELP

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    You probably put the clamp too low on the J pipe to waterbox coupler and its pinching off the water flow.

    There are 3 pisser holes in the bottom of the jacketed portion of the J pip. If the clamp is below these holes water flow will be prevented.

  6. #6
    1BAD07RXP's Avatar
    Join Date
    Jun 2007
    Location
    Chesapeake Bay, South River, Edgewater, MD
    Posts
    105
    thanks jerry i will loosen the jpipe and pull it up and see how she runs.

  7. #7
    1BAD07RXP's Avatar
    Join Date
    Jun 2007
    Location
    Chesapeake Bay, South River, Edgewater, MD
    Posts
    105
    i lifted the jpipe up about 1/2" started it and the samething p1544 after about 30 secs of starting with no water running through it. Got anyother ideas. im afraid of frying my exhaust manifold

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Well, lifting the J pipe up is not what you want to do. It's the clamp itself that may be too low. The clamps have to be way up high near the top of the coupler.

    If the clamps are too low it will pinch off the 3 pisser holes.

  9. #9
    1BAD07RXP's Avatar
    Join Date
    Jun 2007
    Location
    Chesapeake Bay, South River, Edgewater, MD
    Posts
    105
    here are a couple pics does everything look ok?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	waterbox 001.jpg 
Views:	107 
Size:	3.01 MB 
ID:	49121   Click image for larger version. 

Name:	waterbox 002.jpg 
Views:	76 
Size:	2.73 MB 
ID:	49122   Click image for larger version. 

Name:	waterbox 003.jpg 
Views:	100 
Size:	2.92 MB 
ID:	49123  

  10. #10
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    all 3 clamps on the JPipe are TOO CLOSE...

    drop the bottom one done all the way...

    loosen the middle one a tad...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. shorty waterbox install on RXT
    By STSPERFORMANCE in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 11-19-2008, 05:42 AM
  2. shorty waterbox install tips
    By JFizzleJR in forum 4-Tec Performance
    Replies: 27
    Last Post: 06-25-2008, 07:12 PM
  3. Shorty waterbox install question
    By mstennes in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-29-2008, 09:24 AM
  4. Custom "shorty" waterbox by Mark Underwood
    By Green Hulk in forum 4-Tec Performance
    Replies: 82
    Last Post: 05-27-2007, 01:06 AM
  5. My shorty waterbox mod
    By Chezzy in forum 4-Tec Performance
    Replies: 18
    Last Post: 03-04-2007, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •