Results 1 to 4 of 4
  1. #1

    94 SL750 dies right after start

    Trying to fix a machine for a friend, this is what I'm being told:

    The jet ski just fires once and thats it. The dealer filled the block with
    oil for winter storage. I brought it home and tried to get it going but could not get rid of all the oil. You clean the plugs and it fires once and you have to reclean them. The dealer told the previous owner that the fuel system was dirty.


    Now, I know that putting plugs that have been fogged back in is a no-no, and yes, the lanyard is hooked up, though, I'm not positive it's working correctly, can I by pass it? Other than that, any other ideas?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,588
    +1
    1,272
    Quote Originally Posted by TheWanderer View Post
    Trying to fix a machine for a friend, this is what I'm being told:
    The jet ski just fires once and thats it. The dealer filled the block with oil for winter storage.
    I brought it home and tried to get it going but could not get rid of all the oil. You clean the plugs and it fires once and you have to reclean them. The dealer told the previous owner that the fuel system was dirty.

    Now, I know that putting plugs that have been fogged back in is a no-no, and yes, the lanyard is hooked up, though, I'm not positive it's working correctly, can I by pass it? Other than that, any other ideas?
    Filled the block?
    Do you mean just through the spark plug holes, or did the lower end also get loaded up with oil?
    If you crank it with the plugs out, does oil spray out the plug holes?

    What condition is the fuel system in?
    Good fuel getting to the carbs?

    It is not uncommon for the older models to need the entire fuel system checked, and often all new fuel lines, including those inside the fuel tank.

    Sounds like you need to investigate the entire fuel system, and probably clean/rebuild the carbs.

    Also, be aware that the ignition system does not like a weak or old battery. It really likes a fully charged, young battery (10.5 volts or better during cranking). If you have any doubts about the battery, charge it up, or even better, get a new one, and make sure it is charged up.

    While you are in there, check the battery ground connection to the engine block. Be sure it is not corroded.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    There are drain holes on the bottom of the block if you remove the bolts. (1 for each cylinder) That should remove all the oil. Do a crank index to make sure the excess oil didn't hydrolock it. Thoroughly check the fuel system, including the fuel shut off valve, filters, hoses, and carbs. It's not a bad idea to buy a triple outlet fuel pump if the old stocker is still installed. Pretty good idea to replace all the fuel hoses at this point too. If rebuilding the carbs is necessary, use only genuine Mikuni parts. Also, what's the compression on the engine?

  4. #4
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    If it fires,then the lanyard/kill switch is working.Sounds like it's not getting fuel(see Xlint's post) and /or it's loaded with oil.Pull plugs and crank..Is it blowing oil out? If so it's loaded.do what Xlint said about the plugs or crank it at short times till it quits blowing oil. my bets on the carbs.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 06-14-2014, 03:36 PM
  2. Triple Piped 94 SL750 Article
    By SeaLion in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 11-12-2009, 11:17 PM
  3. 94 sl750 wont start!!!
    By ktmrider08 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-24-2008, 03:20 PM
  4. 94 SL750 impellar
    By cdyer11505 in forum Polaris PWC Performance
    Replies: 2
    Last Post: 01-27-2007, 01:57 AM
  5. 94 SL750 Stalling
    By cdyer11505 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 01-05-2007, 11:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •