Results 1 to 6 of 6
  1. #1
    Student of Speed rxpwhistler1's Avatar
    Join Date
    Nov 2007
    Location
    Oakland County Michigan
    Posts
    708

    Feeling a bit stupid

    These forums are very helpful but I am having two issues with my ski that nobody seems to be able to address.....anybody who has any suggestions please advise...

    1.) I pulled the plugs a month before storing and they were a little darker than they should be...noticed every time I ride and pull them...they are just a little more black than they should be.....any ideas of the cause???? Only 32 hrs on the ski...no mods yet except Rive BOV

    2.) when taking sharp or hard turns with the ski, they engine kinda sputters for a second than with the handlebars straight...goes fine again...

    Thanks a lot for taking a look guys.


  2. #2

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    1. The stock ECM is programmed to run 12/1 A/F at idle, 14.5/1 at cruise, and 12.5/1 at WOT. You can't really screw this up unless the MAP or IAT sensors are bad. I wouldn't worry abou it unless your fuel consumption is excessive. For comparison, mine gets between 4 and 6 mpg, depending on riding conditions.

    2. Sounds like TOPS to me, but I'm no expert on how to fix it.

  3. #3
    Student of Speed rxpwhistler1's Avatar
    Join Date
    Nov 2007
    Location
    Oakland County Michigan
    Posts
    708
    thanks Mike, however, I am new on working on these things and have NO idea what TOPS is.....lol

  4. #4

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    If I understand it correctly, TOPS is the mercury switch that kills the engine and closes the crankcase vent when the ski flips over. I've had mine sputter after jumping a wave with the nose high.

    Mike

  5. #5
    bron1c's Avatar
    Join Date
    Aug 2007
    Location
    Guilderland, New York
    Posts
    492
    Tops shuts the engine off and closes all entry ways for oil/gas to get into and flood the engine

    I dont know much but I would think possibly your stearing cable is pinching something?

  6. #6
    Student of Speed rxpwhistler1's Avatar
    Join Date
    Nov 2007
    Location
    Oakland County Michigan
    Posts
    708
    bronic, that is a good point which I never stopped to consider. I will be tearing out the blower tonight..I will take a look at that. That makes a fair amount of sense lol..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I feel stupid asking this - 2011 300x wich entry is for flushing the engine
    By GDM in forum Kawasaki PWC Performance (4-stroke)
    Replies: 28
    Last Post: 04-27-2014, 04:13 PM
  2. Feeling stupid....
    By pbrxp in forum 4-Tec Performance
    Replies: 22
    Last Post: 01-23-2010, 04:39 PM
  3. How do you feel about the changes?
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 11-21-2008, 10:16 AM
  4. Best feeling with your pants on.......
    By seadawg in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-04-2005, 09:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •