Results 1 to 9 of 9

Thread: Riva Heads

  1. #1
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299

    Riva Heads

    i was runin my ski's ysterday and it started to bog a little and back down.. i took off the seat and notice water on the heads by 2 bolts? by the L shaped exhaust. can this b the problem causing the boggin?

    XL1200 Limited
    with 1300 efi motor
    complete stage 2


  2. #2
    Do you have a flame arrestor? If yes, it is possible there might be a leak and the water is getting to the flame arrestor. Run the engine on the flush and check for water leaks at both the head & the exhaust. Sometimes the heads can crack or there might be a small pin hole in the rubber exhaust boot causing water to get to the flame arrestor. You might want to check your engine compression as well....just in case.

  3. #3
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299
    yes i have on flame arrestors

  4. #4
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Kaz you may have a leak in those heads. Dry them up good and check them out again. Make sure the water fittings are sealed well on the head. Could be the water is coming from somewhere else. If you have outer wears put them on the arrestors for now until you solve the leak issue.

  5. #5
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299
    i found the problem..my middle cylinder riva head has a crack in it

  6. #6
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Quote Originally Posted by fastkaz View Post
    i found the problem..my middle cylinder riva head has a crack in it
    That Sucks!!!!

    Sweet Talk Bamf maybe he can help you out with a discount or something from Riva I see he has connections there

  7. #7
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299
    i want to put back on my stock head..do i just bolt it right back on after taking off the riva heads..of course gaskets and sealant will b needed.. and what will i have to tune the efi to?

  8. #8
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Kaz it should be no problem to go back to the stock head. Sorry but I am not up on the controllers so I can't give you any advice where to set it, somebody will jump in and help.

  9. #9
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299
    i already bolted it on but i have to take it back off because the ground wire wliped in betwen the head and the cylinder

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva Head Installation question
    By howestek in forum Yamaha PWC Performance (2-stroke)
    Replies: 28
    Last Post: 03-04-2007, 08:51 AM
  2. riva heads, cooling
    By MDGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-21-2006, 10:13 PM
  3. Riva heads look like crap! (JUST ADDED PICTURES)
    By r33pwrd in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 04-13-2006, 03:04 PM
  4. Riva heads?
    By r33pwrd in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 04-03-2006, 06:37 PM
  5. Riva head question
    By shooter98xpl in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 12-19-2005, 10:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •