Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1
    SoFlaRiders Member mksmi's Avatar
    Join Date
    Jul 2007
    Location
    Tamarac,FL (south Florida)
    Posts
    622

    Filled my ridplate holes today. Took some pics.

    Well I finally filled my rideplates holes today. Thanks for all the advise from everyone on how to do it. I think it went pretty good. This was my first mod. i have done other then washers. Took some pics. if anyone is interested. Also can some who knows let me know if it looks OK. Thanks again.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Picture 001.jpg 
Views:	62 
Size:	646.3 KB 
ID:	49325   Click image for larger version. 

Name:	Picture 003.jpg 
Views:	52 
Size:	560.6 KB 
ID:	49326   Click image for larger version. 

Name:	Picture 005.jpg 
Views:	68 
Size:	622.1 KB 
ID:	49327   Click image for larger version. 

Name:	Picture 006.jpg 
Views:	77 
Size:	604.1 KB 
ID:	49328   Click image for larger version. 

Name:	Picture 009.jpg 
Views:	95 
Size:	657.3 KB 
ID:	49329  


  2. #2
    It looks like a nice clean job. What'd you use?

  3. #3
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    Perfect

  4. #4
    FIRED!!! JP's Avatar
    Join Date
    Dec 2006
    Location
    Fort Lauderdale, FLORIDA baby...
    Posts
    3,505
    Looks great!!!
    (I have to redo a couple of mine, probably this week)

    JP

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by JFizzleJR View Post
    Perfect
    +1

  6. #6
    SoFlaRiders Member mksmi's Avatar
    Join Date
    Jul 2007
    Location
    Tamarac,FL (south Florida)
    Posts
    622
    Thanks a lot guys. I used 80 grit sandpaper to rough up the holes first. I used 3/16 nylon rope to surround the bolts, then cut tape to cover the bolt and rope. Used water-weld epoxy, then sanded with 100 grit then 150 then 300 to finish. Is it OK that when i sanded i went through to the bare aluminum in some spots?

  7. #7
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by mksmi View Post
    Is it OK that when i sanded i went through to the bare aluminum in some spots?

    You are fine, as long as it is flush and no edges are showing...

    Waterweld is the same stuff I used...except I tossed a dab of Right Stuff on the head of each bolt, then attached a stainless washer that just fit in the hole....after it dried I tossed in some waterweld...

  8. #8
    SoFlaRiders Member mksmi's Avatar
    Join Date
    Jul 2007
    Location
    Tamarac,FL (south Florida)
    Posts
    622
    I checked all the holes by running my fingernail across them from front of the ski to the back. I sanded until my nail wouldn't catch anymore.

  9. #9
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    those look real nice ...dont look under mine i filled them but need to finish them ...

  10. #10
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by mksmi View Post
    Is it OK that when i sanded i went through to the bare aluminum in some spots?
    Youll be fine..I acually sanded mine all the way down after installing the skegs..

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Took some pics of pistons sending head to jim
    By Tanny in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 01-26-2008, 10:01 AM
  2. Took Some Pics of the Beach Last weekend.
    By ADAMBOMB in forum Open Discussion
    Replies: 6
    Last Post: 01-17-2007, 11:08 AM
  3. Went riding today....took some pics
    By TorquePhoto in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 10-25-2006, 02:57 AM
  4. Removed SC, took some pics...
    By Pale Rider in forum 4-Tec Performance
    Replies: 32
    Last Post: 12-20-2005, 08:01 PM
  5. Took some pics while pulling off pump
    By Pale Rider in forum 4-Tec Performance
    Replies: 17
    Last Post: 12-06-2005, 10:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •