Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: EFI ISsues

  1. #1
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299

    EFI ISsues

    i have a stage 2 motor ( middle riva head crack back to stock head for now) and the efi is givin a lil problems..i have on the riva setting and wen i rev it it boggs...it also smokes alot. the green light is blinking on the efi and wen rev the yellow light appears.. what can i do the reslove this problem?


  2. #2
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299
    im premix aswell

  3. #3
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    whats your settings

  4. #4
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Are you grounded good?

  5. #5
    Speedaddict's Avatar
    Join Date
    Dec 2005
    Location
    Florida
    Posts
    268
    +1
    2
    cross over setting?
    grounded right?
    what kind of bog? does it make alot of blubbering before actually taking off or does it just fall flat?

  6. #6
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299
    blubbering before actually taking off..i have on the riva setting..im grounded to the exhaust. where the plate goes to support the echaust to the cylinder head.

  7. #7
    Speedaddict's Avatar
    Join Date
    Dec 2005
    Location
    Florida
    Posts
    268
    +1
    2
    well if i knew your efi settings this would be a tad bit easier but.. it's that your runing it too rich from your boggin problem.

    try bringing down the crossover pot (last one) on the efi BEFORE starting to lean down on the green and yellow pot.(first two.)
    again i don't know your efi settings that's why im not recommending to lean it down. and the problem might be the green or yellow just don't want you to go lean it and run it that way.


    (Note:these 05 motors have no PV's and over many tests i noticed that they like to be a little higher on the green and yellow pot than the PV motors. )

  8. #8
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299
    setting are (6,9,1,6)

  9. #9
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    when I was at Jim's last year, he had a similar problem. After pestering him for a while, we switched out my throttle bodies with his and figured out it was the throttle bodies that were not working right. Either the tps is out of whack or one of the other sensors. When he reved the motor I noticed that the 2nd pod would come on intermentaly or not at all. After switching out the throttle bodies, his ski picked up the rpms he was missing. Something to check out if you have the time.
    SHOOTER
    SHOOTER

  10. #10
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299
    any more suggestions on what the problem might be?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Few issues today.
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-20-2005, 09:44 PM
  2. Supercharger Clutch issues..
    By arubenstein in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-26-2005, 12:42 PM
  3. Light to medium Chop riding issues
    By 05rxt in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-22-2005, 11:48 AM
  4. who knows if Seadoo will cure the supercharger issue in 2006
    By rxp_boy in forum 4-Tec Performance
    Replies: 26
    Last Post: 07-17-2005, 09:30 PM
  5. 2003 1300GPR HULL ISSUES
    By RXPNJ in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 06-24-2005, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •