Results 1 to 2 of 2
  1. #1
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153

    After I got my pump back from skat I noticed.............

    That when I went to put in my solas prop, it rubbed ever so slightly on the SS wear ring on one side.

    I went for a test spin and noticed that my RPM's were right at 8100.


    Should I take the prop out and grind it down ever so slightly to eliminate the rub? Or will just leaving it in there will it shave itself down without damage.........


    What say you?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,983
    +1
    1,900
    it will wear in.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Got my carbs back from Jim, but
    By Echo in forum Yamaha Open Discussion
    Replies: 13
    Last Post: 09-03-2013, 03:55 PM
  2. Got the impeller back from Impros
    By 97GPSLEEPER in forum Yamaha Old School Skis
    Replies: 34
    Last Post: 10-12-2009, 04:13 PM
  3. got my ski back from the dealer
    By gba in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-13-2008, 10:11 PM
  4. Got my boat back from Kerry today!
    By WVGP1200R in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 08-04-2006, 11:04 AM
  5. Got my pump back from Skat Trak today
    By Mark S in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-04-2005, 08:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •