Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38

    Pulled the 1050 today

    I pulled the 1050 out of the '97 today. The first think I did was hook up a freshly charged battery to check the MFD. Works good and shows only 32.9 hours.

    The MAG dome looks good but it's broken at one of the bolt holes. The cylinder is smooth, just needs honing. I'll tear it down later tonight or tomorrow but the cases look good and the pistons, as seen through the exhaust, look good.

    Here's some pictures for now. I'll posted detailed pictures after I tear it down and see if we can figure out why it snapped a rod with only 32 hours on the clock.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Picture 085.jpg 
Views:	34 
Size:	551.6 KB 
ID:	52035   Click image for larger version. 

Name:	Picture 074.jpg 
Views:	39 
Size:	570.6 KB 
ID:	52036   Click image for larger version. 

Name:	Picture 100.jpg 
Views:	50 
Size:	531.6 KB 
ID:	52039   Click image for larger version. 

Name:	Picture 102.jpg 
Views:	49 
Size:	569.1 KB 
ID:	52040   Click image for larger version. 

Name:	Picture 103.jpg 
Views:	49 
Size:	613.3 KB 
ID:	52045   Click image for larger version. 

Name:	Picture 106.jpg 
Views:	41 
Size:	594.6 KB 
ID:	52046  



  2. #2
    Bing-A-Ding-Ding-Ding, Brrrrrap! Brrrrrrrrrap!!! Polaris_Nut#1's Avatar
    Join Date
    Aug 2006
    Location
    Pittsfield, MA
    Posts
    3,350
    +1
    26
    NICE

  3. #3

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    i got a std bore top end kit from wsm , i could part with it for that cover

  4. #4
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Quote Originally Posted by 97sltx1050 View Post
    i got a std bore top end kit from wsm , i could part with it for that cover
    The cover was the icing on the cake. When I pulled into the seller's driveway and saw the cover I couldn't wait to see what was under it.

    Doesn't look like I going to need a topend kit. With only 32 hours on it I'm thinking crank work, one piston and a fresh set of rings on all three after honing. If that turns out to be the case the money saved on the TE kit and boring might go towards porting.

  5. #5

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    didnt come with a pump ?

    if so i got a drive shaft

    looks like a sweet ride thank god no sweet deals came around here like that i wouldnt know which project to work on

  6. #6
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Quote Originally Posted by 97sltx1050 View Post
    didnt come with a pump ?
    The ski is 100% complete, If you're refering to the picture above, I had to remove the pump to pull the engine.

  7. #7

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    arg i want that cover , im so jealous if that was my ski i wouldnt let it go for 500 good deal

    i think you need some 40 mm kehins on there , perhaps vforce reeds , high compersion domes ,

    is the cdi updated ?

  8. #8
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    For what you have in it, I would be tempted to leave it stock. You would have a really nice ride and have very little invested in it.

    Then, if you ever decided to sell it you could clear a nice profit.

    Just my 2 cents.

  9. #9
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Looks damn clean!
    Broken crank...38 hours...
    Can't wait to see the pictures of the crank, domes and cylinders.

  10. #10
    AWA Member 32DegH2O's Avatar
    Join Date
    Aug 2006
    Location
    Minneapolis, Mn.
    Posts
    2,008
    +1
    5
    Ya might want to invest in a new starter motor while you have the engine out...that one looks pretty rough.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pulled the plugs today and..............
    By MONSTERMATT in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-02-2010, 05:49 PM
  2. Awesome ride today in South LA! Ever pull the pump with the OEM tool kit?
    By engineermike in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 04-04-2007, 06:21 PM
  3. AWESOME day out on the RXT today, cold water NY :)
    By Shibby1485 in forum 4-Tec Performance
    Replies: 11
    Last Post: 10-02-2005, 06:36 PM
  4. I ran into a couple forum friends on the water today!
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 09-19-2005, 03:18 PM
  5. Got my first mods in the mail today!
    By 05RXPnoob in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-30-2005, 06:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •