Results 1 to 6 of 6
  1. #1
    SpeedStang95's Avatar
    Join Date
    Jul 2005
    Location
    Columbia S.C.
    Posts
    138

    HEy Guys Need Help PLEASE!!!

    I was just trying to put on my new scoop Grate....just now and one of the back bolts where there is 3 on the scoop grate the out side one just turns like the insert ore the helicoil is striped....has any one had this problem I cant even get the stock grate off of the boat........Or know of a fix if that bolt goes into a water passage??

    Thanks in advance


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,961
    +1
    1,886
    The brass insert is spinning in the plastic pump shoe. This is pretty common.

    Take the remaining bolts out and then pull like hell. You will eventually pull the insert out of the pump shoe.

    Once you get it out use some vice grips to hold the brass insert and then use the socket to remove the bolt.

    Obtain some marine epoxy and coat the insert very good and then hammer it gently back into the pump shoe. Let it set up and it should hold just fine.

  3. #3
    SpeedStang95's Avatar
    Join Date
    Jul 2005
    Location
    Columbia S.C.
    Posts
    138
    Ok I will go and pull I was just woried about how strong it was back there if I did Pull on it Hey Thanks
    Danny

  4. #4
    SpeedStang95's Avatar
    Join Date
    Jul 2005
    Location
    Columbia S.C.
    Posts
    138
    Thanks,
    Jerry IT turned out once I got the insert out I tried to break it loose and the bolt broke but I found a bushing at the parts store that was smooth and cut some groves in it and epoxyed it in ... Had to change that one bolt to 1/4-20 but at least it is on .......Thanks for the help

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,961
    +1
    1,886
    Glad it worked out for you. It can be a real pain in the ass when that happens.

  6. #6
    SpeedStang95's Avatar
    Join Date
    Jul 2005
    Location
    Columbia S.C.
    Posts
    138
    YEa it was like pissin in the wind just didnt go right as planned

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New guy needs help with fuel lines...please
    By jdauntless007 in forum Polaris How To & FAQs
    Replies: 17
    Last Post: 05-15-2013, 01:40 PM
  2. Hey guys, JS550 help please
    By sykal in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 06-09-2008, 03:13 PM
  3. new guy....needs help please!!!
    By vadik85 in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 08-18-2007, 02:19 PM
  4. New guy needs help...
    By Watdog in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 10-18-2006, 05:35 PM
  5. Need HELP Please!
    By GeoRXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-30-2006, 08:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •