Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    Went to the lake yesterday

    Went down yesterday for the first ride of the year. Between work and school I have been swamped. Got on the water and realized that I forgot my GPS unit. Mods are 4" air intake, RR exhaust, ride plate wholes filled and reverse bucket mod. Ran 8150 consistently with very little cavitation. It only cavitates when I have a passenger? Does this make any since. I'm going to try to get out next weekend and get some GPS numbers. Any idea what speed I might be running at this rpm with stock impeller?

    Forgot to mention water temps were 66-68 degrees air temp this morning was 55 warmed up to about 62 and I never saw a bit of heat fade. Perfect 6-8 inch chop with a full tank of gas that lasted about an hour.


  2. #2
    Nobody has any ideas?

  3. #3
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    I have vortex sc wheel, no opas, ride plate holes filled, riva intake, riva grate, riva sponsoons, riva exaust. Today I saw 8150 rpm pegged. Dreamo was pegged at 70 and the best gps run I saw was 70.3. I was getting alot of 68's and some 69's and a few spikes of 80 and one of 85. I think I have 71 in her, but the purposing(spelling?) was getting very bad and holding my speed back.

  4. #4
    which means I'm still slow as balls!

  5. #5
    txgp1300r's Avatar
    Join Date
    Apr 2006
    Location
    Dallas , Texas
    Posts
    3,154
    +1
    50
    HEY..70 aint slow....its real real fast if you fall off at 70

  6. #6
    RustySeaRustyDoo's Avatar
    Join Date
    Oct 2005
    Location
    Chesapeake Bay-Pasadena, MD
    Posts
    1,788

    Re: Went to the lake yesterday

    Quote Originally Posted by Cody Townsend
    a full tank of gas that lasted about an hour.
    Are you serious???

  7. #7
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316

    Re: Went to the lake yesterday

    Quote Originally Posted by RustySeaRustyDoo
    Quote Originally Posted by Cody Townsend
    a full tank of gas that lasted about an hour.
    Are you serious???
    the manual says they will only run something like 55 minutes at WOT.

  8. #8
    As a heart attack. When you find water like that you've gotta let her rip. WFO baby!

  9. #9
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,710
    +1
    75

    Re: Went to the lake yesterday

    Quote Originally Posted by RustySeaRustyDoo
    Quote Originally Posted by Cody Townsend
    a full tank of gas that lasted about an hour.
    Are you serious???
    that is correct. If you ever hold it open that long, the needle moves pretty fast.

  10. #10
    txgp1300r's Avatar
    Join Date
    Apr 2006
    Location
    Dallas , Texas
    Posts
    3,154
    +1
    50
    gotta let that pig eat !!! lol

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Waxed a 2012 RXP at the lake Yesterday!:)
    By craig41071 in forum 4-Tec Performance
    Replies: 29
    Last Post: 06-15-2012, 07:40 PM
  2. Replies: 2
    Last Post: 05-27-2008, 02:09 PM
  3. finally went to the lake after hull repair
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 04-13-2006, 11:29 PM
  4. went to the lake
    By jungo in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-19-2005, 05:37 PM
  5. WOT on the ocean yesterday
    By jack in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-03-2005, 02:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •