Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Help!!!

  1. #1

    Join Date
    Jan 2006
    Location
    Holter lake, montana
    Posts
    127

    Help!!!

    i was out riding my ski today(05 rxp) i am still in the break in period. i was just cruzing along and all of the sudden the ski started vibrating and shaking real bad so i shut it off and when i restarted it it would start shaking and vibrating when i got to 3000 rpms. it sounds like somthing towards the back of the ski may be loose. it was not flashing any warning codes or anything like that. does anyone have any ideas about what could be wrong with it. any help would be apreciated.


  2. #2
    You might have something stuck in your impellor.

  3. #3
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    You sucked something up. Check the intake grate area and pump impeller area. Something is in there. Pull it out and your problems should go away.

    You may need to remove the pump if something is stuck between the prop and wear ring.

  4. #4

    Join Date
    Jan 2006
    Location
    Holter lake, montana
    Posts
    127
    ok i will check the pump, but wouldnt it also be vibrating before 3000 rpms if i sucked somthing up.

  5. #5

    Join Date
    Jan 2006
    Location
    Holter lake, montana
    Posts
    127
    any other sugestions, could it be the super charger. the ski only has 5 hours on it.

  6. #6
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,431
    +1
    177
    not likely. Probably just a small piece of wood or trash between the prop, and the wear ring. Check for wear on the ring, if grooved up u should replace it.

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    no supercharger... DEFINITELY something in the pump.

    for all those listening and newbies.... if ur riding along and suck something up and ur ski vibrates and is slow out of the hole... here's what you do.... don't touch reverse! it's useless.

    First thing to try.... turn the ski off... now turn it back on and the same split second that the motor turns on nail the throttle wide open and do not let go for at least 5 seconds... if it don't clear out, let go.

    if this does not work... find a big boat or wake or a wave or something and pick up speed and try and hit the wake so that the ski comes out of the water a little bit and stay on the throttle real hard while it's out of the water

    and if this does not work... get the ski up to speed slowly despite the vibration and go in real fast tight circles as fast as you can causing the ski to cavitate and surge and get air pockets and sporadic flow of water to blast whatever is stuck in there.

    ask the few guys i've ridden with. they sucked up so much stuff and screw around trying to get it out. Option 1 above works 99.999 % of the time.. ski off, turn back on and split second it starts nail the throttle open. try this 2-3 times if it won't work then try the other suggestions.

    there's no reason to idle, panic, or go crazy if ur ski sucks something up. obviously if it's a plastic bag or a rope this will not work.. for all other debris it does.

    yes... i have a TON of experience sucking stuff up

  8. #8

    Join Date
    Jan 2006
    Location
    Holter lake, montana
    Posts
    127
    i am afraid to run it hard because as soon as i get to 3000 rpms it vibrates badly and it feels like somthing is gona break or come loose. i would just let off the throttle when it started vibrating in fear of damaging somthing. but i will try that if it is not going to damage any thing.

  9. #9

    Join Date
    Jan 2006
    Location
    Holter lake, montana
    Posts
    127
    and if that does not work do i have to pull the pump to look in there?

  10. #10
    If it`s sitting on the trailer now in reach, grab a shop light or flash light and look up into the intake grate from the bottom, and the exit nozzle for something jammed in there...PR...

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 05-18-2005, 07:49 AM
  2. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM
  3. help!!!
    By jonstephens in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-16-2005, 10:47 AM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •