Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,442
    +1
    1

    Is it normal...?

    With the new 14/17R prop in and the mods listed below....Is it normal for the ski to jump out of the water insanely? When I punch it, it jumps out of the water and then jumps 2-3 times more until it grabs the water and stays on it.

    I lost rpm's on top from 8100 to 7850....Speed went up from 66.3 to 66.8 with a full tank of 89 octane gas. Temps were 84 air 80 water 76% humidity in light chop. Could not do more testing since it almost sanklike I posted earlier....Taking it to the dealer tomorrow for the 100 hour service. Then back out on Friday to do more testing.

    Any suggestions on re-pitching...?


  2. #2
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,700
    +1
    21
    Use 93 octane. If it jumps,,its hittin.

  3. #3
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,442
    +1
    1
    I had stopped using 93 octane a while ago because I did not see a difference in performance. Now that I have a few other mods I plan to do some back to back testing again to see. I did not put premium last time because it was at $3.12 And it was dead empty!

  4. #4

    Join Date
    Apr 2005
    Location
    Logan Township, NJ
    Posts
    280
    Get used to the prices. You spent a lot of money on a high performance machine and your going to pitch pennies and hurt your engine in the long run. Bad move unless you plan on selling the ski soon. Now for it popping out the hole...You will need to shift your weight close to the handlebars. That will help.

    Peter

  5. #5

    Join Date
    Jan 2006
    Location
    Puerto Rico
    Posts
    691

    Re: Is it normal...?

    Quote Originally Posted by GeoRXT
    With the new 14/17R prop in and the mods listed below....Is it normal for the ski to jump out of the water insanely? When I punch it, it jumps out of the water and then jumps 2-3 times more until it grabs the water and stays on it.

    Bro, for this same reason is why i sold my two %*#*& ^ pump wedges the Riva 2.0 and the R&D 2.5. Listen bro, NO ONE in my riding area is using the pump wedge on their RXT hulls stock or moded, in my opinion this wedges are a WASTE of money PERIOD!!!

    I lost rpm's on top from 8100 to 7850....Speed went up from 66.3 to 66.8 with a full tank...

    Any suggestions on re-pitching...?
    Bro, remove the prop from the ski and take it to PPG and tell them were your rpms are, i am sure that they should know what to do to gain back that missing rpm's.

    P.S. did you buy the tools that i told you in my PM in order to make this job by your self??

  6. #6

    Join Date
    May 2005
    Location
    santa clarita ca
    Posts
    37

    is it normal

    It's normal for it to jump out of the water with a wedge. I did some rigging and ended up with the nozzle in the middle of the slot. You need to get a bushing like the one that is in the top if the nozzle put it in the center and fill both sides for and aft. My RXT has great hole shot. No need to shift your body weight. It stays with my Stage 1.5 RXP up to about 50mph. My RXT is also a stage 1.5. I'm testing my XS power IC today.
    Curt

  7. #7
    Also put your trim all the way down. Other than that it is normal. Trim, shift your weight and work the throttle.

  8. #8

    Join Date
    May 2005
    Location
    santa clarita ca
    Posts
    37

    is it normal

    RXT no trim

  9. #9

  10. #10
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,442
    +1
    1
    I wish it had a trim...By the way..does anyone know why it does not bring a trim?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is this normal???? Plug not connected....?
    By GeoRXT in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-29-2006, 09:01 AM
  2. Is it worth going from Normal OPAS block off to Pro OPAS ?
    By rxp_boy in forum 4-Tec Performance
    Replies: 12
    Last Post: 11-01-2005, 09:18 PM
  3. How much water in the hull is "normal"?
    By Pee2xUSee in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-20-2005, 07:18 PM
  4. Spark plugs... pictures of old and new, Normal?
    By Shibby1485 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-08-2005, 10:12 PM
  5. Does this look normal?
    By joeg in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-19-2005, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •