Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
  1. #1
    Ya Boy Trevor bajaeater's Avatar
    Join Date
    Dec 2005
    Location
    Tampa
    Posts
    1,083
    +1
    19

    pump help need now

    cant get my pump off my drive shaft on my gp1200r. impeller still on is that ok? took cone off and took 7/8 nut off. whats the deal? so confused.


  2. #2
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Well had you ventured over to the how to section you would have found two sticky's on this very subject. I did the leg work for you this time

    edit: Oh yeah almost forgot. Pull that prop off first before you hurt yourself or damage the prop.


    http://www.greenhulk.net/forums/showthread.php?t=41983

    http://www.greenhulk.net/forums/showthread.php?t=10901

  3. #3
    Ya Boy Trevor bajaeater's Avatar
    Join Date
    Dec 2005
    Location
    Tampa
    Posts
    1,083
    +1
    19
    no luck with what i need. the one post tells how to get the shaft in without seals and such well my pump has seals and bearings already in it but thats not my problem. my problem is getting the old pump off my driveshaft and ferchos file says its damaged and wont upload?

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Try this.
    Attached Files Attached Files

  5. #5
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Fercho's file opened right up for me just checked it.

  6. #6
    WE DONT DIAL 911 RDH's Avatar
    Join Date
    Jan 2007
    Location
    LAKE TRAVIS
    Posts
    1,862
    lots of heat and giant clamps!

  7. #7
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Quote Originally Posted by bajaeater View Post
    cant get my pump off my drive shaft on my gp1200r. impeller still on is that ok? took cone off and took 7/8 nut off. whats the deal? so confused.
    Impeller must come off! What are you trying to do?

    Bearings are pressed on the shaft and assembly is pressed in the housing. Everything goes out the back so the prop must come off. Shouldn't need any heat tho.

  8. #8
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Quote Originally Posted by Duke View Post
    Impeller must come off! What are you trying to do?

    Bearings are pressed on the shaft and assembly is pressed in the housing. Everything goes out the back so the prop must come off. Shouldn't need any heat tho.
    I know for a fact the new pump he has already has the bearings installed in it. He was advised (not by me and not here) to take the nut off and tap the shaft to remove from the old pump. Reverse the process to install in new pump.

  9. #9
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Quote Originally Posted by OsideBill View Post
    I know for a fact the new pump he has already has the bearings installed in it. He was advised (not by me and not here) to take the nut off and tap the shaft to remove from the old pump. Reverse the process to install in new pump.

    That won't work. You will damage the bearings and the pump won't last IMO.

  10. #10
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Quote Originally Posted by Duke View Post
    That won't work. You will damage the bearings and the pump won't last IMO.
    That's my opinion also.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ride Plate for Seadoo Pump Conversion - Need Help
    By ercBOOSTED in forum Yamaha PWC Performance (4-stroke)
    Replies: 84
    Last Post: 09-05-2010, 09:16 PM
  2. Need some pump help RFI
    By 785xp in forum 2-Stroke Performance
    Replies: 19
    Last Post: 09-16-2009, 03:16 PM
  3. Still Need HELP and now I'm just getting Pissed!
    By wertz6 in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 07-24-2009, 03:56 AM
  4. GURU HELP needed PUMP, IMPELLER
    By great lakes gpr 1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 02-26-2009, 12:07 AM
  5. Need to replace the pump. HELP
    By Alex Speedster 200 in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 09-12-2007, 02:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •