Results 1 to 4 of 4
  1. #1

    Gauges shutting off

    So I just got my rxp back up and was out testing it out today when I remembered about a problem I was having before:

    Once I get up to about 40mph on the digital speedo the gauge cluster just shuts off, once I slow back down the gauges turn back on. I dont understand what the problem is....please help!


  2. #2
    Gone in 3.0 seconds... RXPT400's Avatar
    Join Date
    Nov 2007
    Location
    USA
    Posts
    1,527
    Have you had your battery disconnected for a long time? Maybe your battery charge is low or your charging system is not charging enough. I will also check for ground and power signal to the unit and its resistance in the wires for short circuit. Also check the connector to see if it is getting loose.

  3. #3
    yup, gotta go thru the routine and check all connections, battery voltage, even tho the low volt would light, battery ground to block, and the secondary grounds as well...

    does it shut off in ALL conditions, or more so when it`s rough?...PR...

  4. #4
    Quote Originally Posted by cubanguerrilla View Post
    So I just got my rxp back up and was out testing it out today when I remembered about a problem I was having before:

    Once I get up to about 40mph on the digital speedo the gauge cluster just shuts off, once I slow back down the gauges turn back on. I dont understand what the problem is....please help!
    mine does the same thing everytime I get air. when I land...the information center shuts off for a second and reset to zero. The only thing I don't have secured is the 2 30 amp fuse that powers the whole ski. I am in the process of relocating these for easy access. Good luck.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Newbie Question - MFI panel won't shut off
    By bslus in forum Polaris Open Discussion
    Replies: 12
    Last Post: 06-05-2008, 09:00 AM
  2. HELP - R12x Shuts Off and adjust Idle Question
    By tomasga in forum Honda How To & FAQs
    Replies: 5
    Last Post: 06-21-2007, 08:55 PM
  3. What causes ski to shut off/cut out?
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 05-28-2007, 03:43 PM
  4. Help! Pulse line and fuel shut off ??????
    By lodough780 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-24-2007, 04:59 PM
  5. Problem rxp keeps on shutting off
    By asiansurfer7285 in forum 4-Tec Performance
    Replies: 21
    Last Post: 12-12-2005, 11:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •