Results 1 to 2 of 2
  1. #1

    05 RXP electrical problem

    I have a 05 RXP with electrical problem.
    Ski sat for a year and I rebuilt it.
    Jumping the starter the motor will crank.
    Per the BUDDS system it states the starter relay was open, shorted or grounded.
    I have replaced the solonoid with a new one and it still has the same problem.
    On the solonoid I get 12v on the bottom, The top going to the starter I get nothing.
    There is a plug that goes to solonoid, it has a purple and brown/yellow wire.
    The purple goes to the bank 2 on the mpem.
    The brown/yellow goes to the ECU.
    Does anyone knows what voltage I should get from the 2 wires?
    Any help would be appreciated.

    Thanks Roger


  2. #2
    You have a PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 RXP gauge problem
    By b&v in forum Sea Doo How To & FAQs
    Replies: 0
    Last Post: 09-09-2014, 04:08 PM
  2. 05 RXP steering problem
    By trbojas in forum 4-Tec Performance
    Replies: 1
    Last Post: 02-07-2014, 11:37 PM
  3. ???????05 rxp rpm problem???????
    By rxpredviper in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-14-2009, 12:57 PM
  4. '05 Rxp Problem Please Help
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2006, 03:02 PM
  5. 05 RXP Starting problems
    By Cody Townsend in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 05-09-2006, 05:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •