Results 1 to 8 of 8
  1. #1
    camar0's Avatar
    Join Date
    Apr 2007
    Location
    Sunshine
    Posts
    787

    Question Why does Starter relay keep going bad?

    I let water stay in the hull last year about 4 months without even realizing that... lol... yea thats bad.... i noticed the starter relay was bad so i replaced it...

    the ski ran in november but also the battery was poor so i just replaced that today finally...

    however now the damn ski wont turn over again... if i jump the 2 ports on the starter relay, it will turn over.... seems i have to go spend another $35 so i can ride tomorrow...

    what is making this relay go bad again? any ideas?


  2. #2
    are all your connections clean? How about the plug connector? mounting surface? battery cables in good shape? and block/ground connection?
    low batt voltage or too high voltage will kill contact in the solenoid...

    or it could just be a coincidence...PR...

  3. #3
    2k7rxp's Avatar
    Join Date
    Dec 2007
    Location
    Lake Michigan
    Posts
    59
    i kind of had the same problem at work with a semi it would start if you jump the solenoid but would crank slow with the ignition switch doesn't make sense but it was the starter having too much resistance so maybe get the starter tested?

  4. #4
    camar0's Avatar
    Join Date
    Apr 2007
    Location
    Sunshine
    Posts
    787
    well i replaced the relay again and still wont turn over with button... damnit to hell!

    if i touch the 2 power leads together the ski will turn over... wtf?

    is this electrical or bad starter?

  5. #5
    Quote Originally Posted by camar0 View Post
    well i replaced the relay again and still wont turn over with button... damnit to hell!

    if i touch the 2 power leads together the ski will turn over... wtf?

    is this electrical or bad starter?
    now that`s a dif story , did you prove the switch? did you prove the circuit for the start/stop switch?...PR...

  6. #6
    2k7rxp's Avatar
    Join Date
    Dec 2007
    Location
    Lake Michigan
    Posts
    59
    try a buddies start/stop switch or make your own with a push button switch to eliminate the factory switch. or try your starter with someone elses. see if a tech at your local dealer has a starter laying around and swap yours with it

  7. #7
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    make sure the throttle butterfly is not sticking I found if the butterfly isnt on the stopper when you put lanyard on it wont crank!

  8. #8
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Take the switch apart and clean it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Why does this Joint keep braking??????
    By jwaked in forum Yamaha PWC Performance (4-stroke)
    Replies: 18
    Last Post: 12-19-2015, 03:28 PM
  2. My fuel pump(s) keeps going bad.
    By gr4ph1c in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-15-2012, 09:10 PM
  3. 94 sl750 MFD keep going bad
    By polarisman in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-23-2010, 07:49 PM
  4. Replies: 1
    Last Post: 04-02-2010, 09:41 AM
  5. How often does this go bad?
    By peteshauling in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 05-31-2006, 08:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •