Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1

    Join Date
    Feb 2008
    Location
    Perth, Western Australia
    Posts
    227

    Question GTX DI - First ride issues (help!)

    Hi,

    I picked up an 03 GTX DI last week and we took it out for the first time over the weekend. Saturday the ski just did not want to go, was missing under load and engine would not rev clean, max revs were around 5800rpm. Would not go over 25mph. After 30min in water I took it home. Got some new plugs that day and replaced plugs (old plugs were pretty black).

    Next day the ski felt better on the water, it would rev to 6500rpm but it was still down on speed, got to 35mph max. It ran ok for about an hour and then started to miss again under load and break down. Might have fouled the plugs again? I also noticed that it is cavitating a bit so I am going to replace wear ring, impeller looks ok but I have not pulled the pump out yet. Wear ring is black, so it might have never been replaced??

    It has done 100 hours and the whole ski looks like new both in and out, but its running like a pig.

    Can some please suggest what I can do/check to rectifly the engine missing problem? I am going to clean the REVA valves and also take the new plugs out and see what state they are in. What could cause it to run that rich to foul new plugs after an hour?

    What basic things should I be checking, which could cause engine to die and not want to rev?

    The impeller is stock, what sort of RPM should a 951DI be pulling the water? I tought closer to 7000rpm? Also it is down on speed, but I am guessing that is a combination of cavitating and low revs.

    Cheers!!


  2. #2

    Join Date
    Feb 2008
    Location
    Perth, Western Australia
    Posts
    227
    Spoke to a jetski mechanic today and he said that my problem sounds to be ignition related. He told me to strip the spark plug leads back and reclap them as they are common to corode and result in a loss/lack of spark causing engine breakdown.

    I am also going to replace the waer ring, fuel and oil filters and clean the REVA valves.

    Anything else I should look at, clean or replace while I am at it??

    Cheers.

  3. #3
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    Definately clean the Rave valves.. The fuel filter is about $125 or so.. You'll need the fuel line tools to replace, but it's easy to do.. If the stuff you mentioned doesn't doo it, then You may have to replace the fuel pump assembly itself.. Notorious for going bad and being erratic and hard to diagnose.. been there done that...
    The pump assembly is about $800 or so, so try the little stuff first..
    You may also want to replace that little check valve solenoid that goes to the raves.. You can check with PPG to get part #..
    Normal rpm's on a di is about 6600 give or take and mph is only 51-52 on a stock ski.. Good Luck

  4. #4

    Join Date
    Feb 2008
    Location
    Perth, Western Australia
    Posts
    227
    Quote Originally Posted by Foggy View Post
    The fuel filter is about $125 or so..
    Are you sure that they are that expensive? I found some online for under $20. I'll get them of the local SeaDoo dealer when I grab the wear ring later today.

  5. #5
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    maybe it was $100 or so.. It's a canister type with the high pressure hoses built into it.. Like an "assembly"..
    I had 1 overnighted to me last 4th of july week to try and fix my issue..
    Ended up having to replace the pump a couple weeks later.. but that finally fixed it up right and stayed right.

  6. #6

    Join Date
    Feb 2008
    Location
    Perth, Western Australia
    Posts
    227
    I went to SeaDoo dealer and bought an inline filter. Spoke to the mechanic there and he told me they dis not have the filter with the hose assemble so he gave me one without the assembly and said to just the old filter out and use high pressure fuel injection hose clamps and put the new filter in.

    Replacement filter cost $70 Australian dollars, so about $60 US or there abouts.

    I am in the process of doing a major service on it now. Pulled the injectors off last night too and will get them cleaned. Doing all filters and checking antire cooling and air injections system. Replacing the coil leads etc. I found that the OPAS is blocked and was not working as it should, so while I have the jet pump out i'll sort the OPAS out too. Also the RAVE valves looked pretty average when I pulled them out.

    What else can cause a drop in engine revs?? I was about 500rpm down as the 951DI should run about 6900rpm in water from what I have read.

    Its a good learnign experiance, as I never worked on jet ski before but they are not too bad once you know how it all slots together
    Last edited by XtRmn8; 02-04-2008 at 10:41 PM.

  7. #7
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    remove the OPAS completely and cover the holes with blockoff plates.
    less maintenance and interference with handling.
    do a search in the 4stroke section on blockoffs.
    it is a high pressure fuel system so be careful with replacing the fuel filter.
    fuel pump wasa common problem on the 2003 DI, and expensive to fix. you can diagnose by checking fuel pressure and flow... best left up to a dealer. is the ski definitely running the correct oil?
    what is the compression on the 2 cylinders?

  8. #8

    Join Date
    Feb 2008
    Location
    Perth, Western Australia
    Posts
    227
    Quote Originally Posted by lextoy View Post
    remove the OPAS completely and cover the holes with blockoff plates.
    less maintenance and interference with handling.
    do a search in the 4stroke section on blockoffs.
    it is a high pressure fuel system so be careful with replacing the fuel filter.
    fuel pump wasa common problem on the 2003 DI, and expensive to fix. you can diagnose by checking fuel pressure and flow... best left up to a dealer. is the ski definitely running the correct oil?
    what is the compression on the 2 cylinders?
    If the OPAS gives me more greif I will remove it.

    It is runniging XPS 2 oil as per the book. I did not do a compression test, but I will do one once I put it all back together. At the moment the fuel rail is off to get the injectors cleaned.

    What comp should I see, 155-160?

  9. #9
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    Not even a full level 1 PPG di engine hits 6900.. Mine is full level 1 and the best I have gotten is 6750.. even with diff. impellers and tweaking..
    Good luck for 6900 though

  10. #10

    Join Date
    Feb 2008
    Location
    Perth, Western Australia
    Posts
    227
    While searching I found the following in an old thread where someone with a 951DI could only get it to rev to 6500rpm.

    .....the water regulating valve on top of the waterbox could be bad, allowing too much water into the midpipe at high rpm.
    What is a waterbox? I know there is a water regulator sitting on top of a big cylinder type enclusure (I thought that this is part of the exhaust?). How can I check the water regulator, can it be or is it a replacement job?

    Cheers

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 GTX 155 High Idle issues **HELP**
    By Josh-o-matik in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-10-2015, 11:22 AM
  2. 2001 seadoo gtx di fuel pressure issue!!
    By astral in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-11-2013, 09:39 PM
  3. 260X....First Rides Issues
    By CrazyCooter in forum Kawasaki PWC Performance (4-stroke)
    Replies: 24
    Last Post: 05-03-2010, 09:11 PM
  4. Stage one kit's first ride, need help
    By rdm190 in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-10-2008, 08:26 PM
  5. First Ride On Modded Gtx Sc Today.
    By carl sagan in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-26-2007, 05:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •