Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28

    GTX Exhaust leak??

    03 GTX/Free Flow exhaust/Opas blocked/single waterbox ...What the hell connects to this????

    dealer replaced it,went to lake and water is pouring in threw here!!
    I don't see a hose anywhere down there that would hook up to it??(and it seems like it was blocked off on the original one) Thanks
    Last edited by Kaybat; 02-06-2008 at 05:01 PM.


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    you should of had a hose for that. That is the stock exhaust tube and that hose should have been left there and not removed. I can not remember were the hose connects to the motor/exhaust? That is the hose that I used to connect to the riva thru hull water pisser in exhaust pipe. On my rxp with riva thru hull, the hose was connected to a tee that was installed between the hose on the bottom end of exhaust manifold and went to the bottom of the j pipe. May be someone will chime in.

  3. #3
    2006 RXT dave262626's Avatar
    Join Date
    Nov 2007
    Location
    Kansas
    Posts
    164
    Looks like the exhaust cooling bypass waterline. This line is at the pump transom. It should hook to your exhause pipe & be blocked off at the transom. Riva racing has instructions online for the rear exhaust kit.

  4. #4
    KenDude, what pipe is that?...PR...

  5. #5

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    I believe it comes off the J pipe to that cooling nozzle.

  6. #6
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    Andy man- its the stock rear composite piece that exits by the pump....can't figure it out,cause on the original one, it seems that outlet was blocked off.....Its a free flow, not a thru hull exhaust setup....?

  7. #7
    nothing connects to that on an 03 GTX. the hose barb is there from the factory but it is not drilled on that model

  8. #8
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    thats what i thought....thanks everyone!

  9. #9
    Quote Originally Posted by Kaybat View Post
    thats what i thought....thanks everyone!
    KenDude, did you check to see if that port is opened up? I thought you said you were taking on water ...PR...

  10. #10
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    my o3 gtx had a stock hose going to that nozzle. the hose that was going to that nozzle is now going to the nozzle on the riva metal pipe. I am in costa rica now or I would look at my ski and tell you were it went from.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GTX exhaust leak
    By joey0909 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-16-2011, 02:33 PM
  2. Exhaust leak problem.
    By IowanGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-15-2007, 04:26 AM
  3. slx 1200 exhaust leak
    By charles32443 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 06-29-2007, 08:14 AM
  4. Exhaust leak issue
    By jonjonwells in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-31-2007, 07:56 PM
  5. Exhaust leak = RPM's????
    By big83bronco in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 07-06-2006, 07:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •