Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1

    Join Date
    Jul 2005
    Location
    Miami, fl
    Posts
    223

    Stage II on RXP problems

    My rxp wont pass 66MPH with stage II and before did 72 on stage I.
    Engine wont pass 7650rpm, before was 8100-8050. I have the 15/20r.
    Any sugestions
    Thanks


  2. #2
    ramnj's Avatar
    Join Date
    Apr 2005
    Location
    New Jersey
    Posts
    1,716
    Check ALL your connections, specially around the IC and the front on the engine where you plugged the engine after you removed the stock intercooler.

  3. #3
    Check your air lines. Sounds like one may not be fully connected.

  4. #4

    Join Date
    Jul 2005
    Location
    Miami, fl
    Posts
    223
    I will do that...
    I checked my oil dip stich and is over the limit line by 1/4 of inch.
    Is that a problem with rpm having too much oil..
    Thanks

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,980
    +1
    1,898
    YES! that is waaaaay high and will rob you of precious RPM's

  6. #6
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    Also put some Ultra Black on your IC blockoff if you haven't already.

  7. #7
    NottaPhireMan's Avatar
    Join Date
    Aug 2005
    Location
    SoCal, Glamis or The River
    Posts
    72
    +1
    1
    Quote Originally Posted by Green Hulk
    YES! that is waaaaay high and will rob you of precious RPM's
    Are you serious?

    I ask because last summer after getting the RXP just broke in I was able to hit 69 mph w/ 12-13hrs on it. Brought it home, got the 10hr service done @ the dealer in august & parked them in the garage till last weekend. Could'nt get the darn ski above 64 mph all weekend.

    Scratching my head wondering what the problem is.

  8. #8

    Join Date
    Jul 2005
    Location
    Miami, fl
    Posts
    223
    What ca I use to take the oil out, I have never changed the oil. only the dealer.
    Thanks

  9. #9
    Oil level when returned from the dealer is ALWAYS to high. Check your oil and you will see its over the high mark. To remove some oil you will need an oil extraction pump (someone please post a link) and then you can pump some out. TThe difference is HUGE

  10. #10
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    9,371
    +1
    623
    This is mine and it is cheap.

    http://cgi.ebay.com/ebaymotors/TEMPO...38997453QQrdZ1

    Same as Rivas unit.

    .

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 rxp problems
    By kd's rxp in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 05-04-2006, 07:41 AM
  2. Troubleshooting the Rotax Racing Stage I kit (was problems)
    By Jarrett in forum 4-Tec Performance
    Replies: 104
    Last Post: 10-22-2005, 08:12 PM
  3. Odd RXP Problem Happened Again????
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-19-2005, 01:23 PM
  4. Riva stage 2 , 04 RXP
    By 111toybox in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-13-2005, 10:20 AM
  5. First time out with stage 1 05 RXP Not happy.
    By Fastcat in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-10-2005, 09:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •