Results 1 to 5 of 5
  1. #1
    Teddy57's Avatar
    Join Date
    Nov 2005
    Location
    NY
    Posts
    142

    RXP First Ride....RPM Question

    Rode my RXP for the first time, I love it. Question though...I only saw around 7400-7450 for RPM's and around 65-66 on the dremo but there was quite a bit of wind and some chop. Is this normal? Right now I only have the Rotax pipe installed as far as the engine stuff, and it has a fresh set of plugs. Just wondering what you guys thought about the RPM's?


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,431
    +1
    177
    Those rpms are pretty low. check your oil level. It needs to be right in the middle of the 2 bends when fully hot. Over filling can cause rpm loss. Also do you have a solas prop? Check your nose cone to make sure it didn't move up the drive shaft.

  3. #3
    new machine with those mods?
    or used with those mods and you are riding it for the first time?...PR...

  4. #4
    Teddy57's Avatar
    Join Date
    Nov 2005
    Location
    NY
    Posts
    142
    It is brand new. I put 1.9 hours on the machine and never saw my rpms above 7400-7450 at any time. Keep in mind that only the Rotax Power pipe is installed, I have not installed the rest of my mods.

    It was a 2004 left over, I guess it could be possible that the dealer changed the oil because the ski sat around for a while, but I did not think to check the oil after the engine was up to temp....

  5. #5
    Teddy57's Avatar
    Join Date
    Nov 2005
    Location
    NY
    Posts
    142
    Anyone?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 07 Rxp First Ride Bad Supercharger I Think
    By 07 RXP in forum Sea Doo Open Discussion
    Replies: 22
    Last Post: 07-06-2007, 10:04 AM
  2. First Ride, couple questions...
    By bryan428 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-20-2007, 07:37 AM
  3. Just got a 06 RXP --first ride today
    By sabor in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-26-2006, 11:22 PM
  4. 05 RXP first ride. FUN FUN FUN
    By fenderu2 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-30-2006, 10:28 PM
  5. RXP First Ride...RPM Question
    By Teddy57 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-16-2006, 06:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •