Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 40
  1. #1
    yami_rida#26's Avatar
    Join Date
    Oct 2007
    Location
    Cayman Islands
    Posts
    2,112

    How-to-install leo's holeshot kit

    Just purchased the kit tonight feel pretty good on installing it by myself and with some help from a friend from my understanding you grind the rivets on the back bumper off and you place the kit in the space glue it on with 5200 and use sum sort of jack to hold it in place and let it cure for about 24 hrs. if there's anything wrong please let me know open to any other suggestions on installation thanks in advance.


  2. #2
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    You should sand the Piece and the inner rub rail so the 5200 can stick properly.You can scuff it with a scotch brite.I used multiple clamps to hold it on.When using a clamp,put a piece of wood or something flat across the mats so they will not get any damage.This will distribute the weight.I also used a floor jack and wood for one section.

  3. #3
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Did you guys cut the rear lip in the rubrail ? HOw did you handle the rivets that hold the rear rub rail in ?

  4. #4
    yami_rida#26's Avatar
    Join Date
    Oct 2007
    Location
    Cayman Islands
    Posts
    2,112
    i'm installing mine this weekend was also wondering the same.

  5. #5
    txgp1300r's Avatar
    Join Date
    Apr 2006
    Location
    Dallas , Texas
    Posts
    3,381
    +1
    165
    you just need to grind a little off the rivit...not enough to make rivit fail just the tit . I puy minr on w/o scuffing or anything else....5200 sticks like crazy...I did get two big bolts to clamp it in rear and two sticks to wedge under sides...works fine.

  6. #6
    African-American
    Join Date
    Feb 2007
    Location
    Cape Town, South Africa
    Posts
    2,226
    +1
    88
    are you still required to cut the rub rail down ?

  7. #7
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Quote Originally Posted by spaceman View Post
    are you still required to cut the rub rail down ?
    From what I understand - To get it to fit no....To have it reduce the drag yes.

  8. #8
    yami_rida#26's Avatar
    Join Date
    Oct 2007
    Location
    Cayman Islands
    Posts
    2,112
    does anyone know how to pry off the bottom of the stern eye holes (black&white pieces) where the holeshot kit goes.

  9. #9
    yami_rida#26's Avatar
    Join Date
    Oct 2007
    Location
    Cayman Islands
    Posts
    2,112
    plz

  10. #10
    African-American
    Join Date
    Feb 2007
    Location
    Cape Town, South Africa
    Posts
    2,226
    +1
    88
    Um, thye unscrew. There is a large plastic nut on the bottom of them.

    If u get stuck, just grind them off.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 08-18-2015, 02:42 PM
  2. Msx 150, how to install oil tank upgraded kit??
    By lopezmabin in forum MSX/Matrix
    Replies: 6
    Last Post: 08-06-2012, 12:35 PM
  3. Pictures of installed Leo's holeshot kit
    By o uncola o in forum Yamaha PWC Performance (2-stroke)
    Replies: 24
    Last Post: 06-15-2011, 09:46 PM
  4. How to Install Leo's Holeshot Kit w/pics
    By NeVerMind in forum Yamaha How To & FAQs
    Replies: 14
    Last Post: 02-15-2011, 02:09 PM
  5. How to install R&D Auto trim kit?
    By justcosta in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-04-2008, 02:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •