Results 1 to 10 of 10
  1. #1

    2001 RX DI only runs when start is held

    I have a 2001 RX DI that will start up within the first crank and then die out when you let off the button.. It will stay running as long as you keep the button pressed.. ANY IDEAS would be appricated...

    I check a few things out already.. ohmed out the start/stop=ok...ck fuel fuel pump flow and pressure=ok


  2. #2
    Had a carb 951 do that same thing and it was the tps

  3. #3
    2Blue's BFF! dsolie's Avatar
    Join Date
    Apr 2007
    Location
    Olympia, WA
    Posts
    832
    +1
    1
    Does the starter remain engaged?

  4. #4
    yes it acts like the throttle smart cable on a 1998 xp limited.. but this dont have that cable.. yes pretty sure the starter keeps running while the button is held. but it just quits as soon as let off.. checked a whole bunch of things .. last thing to do is buy mpem..

  5. #5
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    Did you check fuel pressure? DI's had poorly built fuel pumps from the factory.

  6. #6
    2Blue's BFF! dsolie's Avatar
    Join Date
    Apr 2007
    Location
    Olympia, WA
    Posts
    832
    +1
    1
    Quote Originally Posted by Foggy View Post
    Did you check fuel pressure? DI's had poorly built fuel pumps from the factory.
    Yhea, but that wouldn't explain why it runs fine as long as the button is pressed.

    Do the gauges light up as normal with out the key installed when you press the buton?

    Any work done to the motor / electrical system lately? Is your solenoid clean and all teminals are in good shape? I beleive the MPEM draws it's power off the power side of the solenoid.

  7. #7
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    I don't know a DI, but it seems that a safety is open which has to be proven closed, upon letting up on the start button. Is there a fuel pressure switch or something? If not a safety, maybe your MPEM can be reflashed to correct the problem.

  8. #8
    I've ohmed out just about every electrical component from the mpem harness back , going off the specs in the manual.. fuel pump pressure is good , also you can clearly see the injectors spraying fuel with the plugs out.. My guess is the Mpem.. so I 'll know tomorrow , i got one coming with the key..its from a 2000 gtx di .. hope it works just for test purposes.. I'll let you know ..thanks

  9. #9

    Smile

    just plugged up the new used mpem and starts and runs perfect... thanks all..

  10. #10
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Thanks for the update!

    DI's...things that make you go hmm...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 XP will only run when holding the start/stop button.
    By Mack in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 09-01-2014, 10:06 AM
  2. Replies: 9
    Last Post: 07-31-2013, 06:01 PM
  3. Replies: 0
    Last Post: 06-01-2010, 07:36 AM
  4. 2001 Rx Di
    By Wacko in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-04-2007, 03:10 PM
  5. What spark plug for 2001 RX DI
    By 111toybox in forum 2-Stroke Performance
    Replies: 5
    Last Post: 03-13-2007, 09:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •