Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1

    Loosing RPMs....help

    I'm loosing rpms with my Riva Stage 2 RXP. Right after I installed the Riva kit I was running 8100, next weekend it dropped to 7800. It stayed at 7800 for quite a while. The other day it was only turning 7600 in the morning, then down to 7400 in the afternoon. The next day I was down to 7200. No matter what prop I put in the revs still stay the same. I have a new wear ring and have the correct oil level. I have used silicone to seal the IC block off as well. My RR HD clutch is slipping at 11 N-m which is close to the maximum.

    I've searched for air leaks but can't seem to find any. I'm really puzzled with what's happening.

    John


  2. #2
    Is your impeller cone still intact ?
    For S & G's last resort try new spark plugs.

    What prop are you running ?

  3. #3
    CRS's Avatar
    Join Date
    Jul 2005
    Location
    Auckland, NewZealand
    Posts
    335
    A friend of mine was having the same sort of problem with his RXP and it turned out the Flexi part of his J pipe had cracked and was dumping exhaust gas into the hull. Not a lot but enough to rob the engine of clean air and as a result it dropped rpm`s. Try running with your seat off and see if your rpms come back.

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,976
    +1
    1,895
    John, have you checked the slip moment on your clutch? This is a classic symptom of a slipping clutch.

  5. #5
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,422
    +1
    176
    howz the oil level? too high will rob rpms

  6. #6
    Green,
    I have checked the slipping moment of my RR HD Clutch (just the clutch kit, without the RR shaft). It is slipping at 11 N-m. I think this still sounds good. What do you think?

    Oil level on operating temp is a little below the middle of the two bends. I also tried removing the seat, I only gained 50-100rpms. Impeller cone is still on. I`ll try a set of new spark plugs though.

    John

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,976
    +1
    1,895
    Slip moment and oil level are good to go.

  8. #8
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    Have you had any drastic weather changes? You can loose 300-400 RPM by the air temp going up 30 degrees. 900 RPM though, not sure. Did you get any water in the hull? More than usual? Do you sub the ski at all?

  9. #9
    BIG BOOST stickem's Avatar
    Join Date
    Jan 2006
    Location
    florida
    Posts
    1,185
    if you ride in saltwater flush intercooler out could be blocked with sand hook your hose up and flush it for 5 mins or so this has happen to a friend hope it helps you

  10. #10
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,422
    +1
    176
    Pull your IC block-off, and silicone the hell out of it, you could be loosing boost through there

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can't get passed 3500 RPM...HELP!
    By NewYork69 in forum 2-Stroke Performance
    Replies: 11
    Last Post: 06-09-2008, 02:26 PM
  2. polaris msx 150 burning oil limeted rpm help plz
    By ln69bt in forum MSX/Matrix
    Replies: 22
    Last Post: 04-09-2008, 10:54 AM
  3. 2003 GTX SC not getting up to Speed Or RPMs ! Help !
    By RXPBeast in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-11-2006, 09:32 PM
  4. Loss of RPMS! Help
    By Chrisrokc in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 06-06-2006, 06:04 PM
  5. RXT 2005 Loose Hose - HELP PLEASE
    By BrAinZ in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-12-2006, 12:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •