Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Feb 2006
    Location
    Birmingham AL
    Posts
    2,924
    +1
    2

    Hose in the RXP water pump

    Maybe I am retarded but I just dont understand how this works can some please help me understand?

    First question: if the hose is sealed to the cover then how does the impleer pump water?


    Second question: in the new open loop kits there is a bolt and nut with the kit where the end of the bolt is ground down what is this for. We did have this on the first kits

    Neil sorry for jacking you picture


  2. #2
    fabrication guru rapidacceleration's Avatar
    Join Date
    May 2005
    Location
    Lake Travis austin, TX
    Posts
    1,156
    +1
    2
    http://greenhulk.net/forums/showthread.php?t=47143

    its a low point drain..
    and you can remove the water pump impelor. some people have left it on.. it now does nothing anyway. the water is supplied by the pump, "oldschool"

  3. #3
    fabrication guru rapidacceleration's Avatar
    Join Date
    May 2005
    Location
    Lake Travis austin, TX
    Posts
    1,156
    +1
    2
    oh if its the 5 hole plate the 3rd hole down is a m12-1.5...
    and is for relocating the temp sensor from the head if you run reverse cooling.
    it the same thread as the locking pin plug on the block, right below the temp sensors and under the intake..

  4. #4

    Join Date
    Feb 2006
    Location
    Birmingham AL
    Posts
    2,924
    +1
    2
    Here is what I am talking about
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	water pump.jpg 
Views:	81 
Size:	615.3 KB 
ID:	59926  

  5. #5

    Join Date
    Feb 2006
    Location
    Birmingham AL
    Posts
    2,924
    +1
    2
    WOW thanks for the qucik responce

    Ok so if I understand this right loose the impller and run regular cooling flow I dont need the bolt thingy right?

  6. #6
    fabrication guru rapidacceleration's Avatar
    Join Date
    May 2005
    Location
    Lake Travis austin, TX
    Posts
    1,156
    +1
    2
    well the pisser is ment to drain all the water out of the block when you pull out the boat. its explained in that link.. some people are filling that area with silicone, but this will keep all the water in the block so if your not in a cold climate and are not worryed about retaining water then that would be ok. i do like the hose around the shaft idea...
    whats the id of that hose you are useing??
    and how long exactly are you cutting it.
    my next revision I may put a boss there to help hold that hose in place.

  7. #7
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    You can find the info here.
    http://www.greenhulk.net/forums/show...t=39993&page=2 on post 11-15.

    This is exactly what I'm planning to do, along with find someone to build a cover that has the holes I need in it to run reverse cooling. Plus it will have a grease fitting.

  8. #8
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    just pop the pto cover off, cut the oil pump shaft and pay someone a few dollars to weld the hole where the shaft was...

    that's the most idiot proof thing that will last forever IMO

    it's really easy... thats how mine is done

  9. #9

    Join Date
    Feb 2006
    Location
    Birmingham AL
    Posts
    2,924
    +1
    2
    Shibby is there anything to watch out for in do that?

  10. #10
    ISLAND RACING seadoo951's Avatar
    Join Date
    Jan 2007
    Location
    Longisland, NY
    Posts
    843
    What is the grease fitting for?

    Quote Originally Posted by Hydrotoys View Post
    You can find the info here.
    http://www.greenhulk.net/forums/show...t=39993&page=2 on post 11-15.

    This is exactly what I'm planning to do, along with find someone to build a cover that has the holes I need in it to run reverse cooling. Plus it will have a grease fitting.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is the RXP hull/pump THAT bad?
    By engineermike in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-27-2007, 09:38 PM
  2. Is there something in the CA water???
    By CrazyA in forum Open Discussion
    Replies: 3
    Last Post: 05-06-2007, 08:30 PM
  3. Crud in the rear carb pump
    By ou812 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-02-2006, 11:57 PM
  4. I Just Changed Oil to Synthetic in the RXP
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-31-2005, 10:02 PM
  5. I might have a oil leak in the RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-02-2005, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •