Results 1 to 8 of 8
  1. #1

    Newbie...VX110 RPM and Speed question

    Hi all...great forum. Have a quick question regarding speed and RPM of my 2006 VX110. My qustion is that the VX seems to run very high
    RPM at low speed. at 5 mph i think it is running at about 5k rpm. Top speed is 49 MPH. So..the VX goes from 5MPH to almost 50MPH in the 3K RPM between 5K and 8K. Is that normal for this craft? Mine was purchased used at 400 hours. It was a freshwater rental and overall is in great shape. I only paid $2K so not too concerned if i have to spend a few bucks for a new impeller if required. From what i have read i think the top speed is a little low so i am thinkking the wear ring/impeller is worn. What do you guys think?
    Last edited by beckel; 03-02-2008 at 04:15 PM.


  2. #2
    Brewster's Avatar
    Join Date
    Aug 2007
    Location
    Cape Cod, Ma.
    Posts
    317
    Yes it's time for a new impeller and possibly a new housing. The dreamo should be reading 57-60 mph.

    If you take a bright lamp put it under your intake grate and look through your jet nozzzle, you will be able to see how much of a gap you have between your impeller and housing.

    When new, you can barely see any light.....just a hair. If it looks passable, get a gps reading, speedo pick-up could be not reading right.

  3. #3
    Brewster's Avatar
    Join Date
    Aug 2007
    Location
    Cape Cod, Ma.
    Posts
    317
    Oh by the way...Welcome.

  4. #4
    Brewster...thanks a ton for the reply. How can i tell if the housing needs to be replaced and not just the impeller. There is definitely too much of a gap between the impeller and housing but i cant tell if it is the impeller or the housing that is worn. Where do you recommend i purchase both of these items? Thanks again!!

  5. #5
    italianstallion314's Avatar
    Join Date
    Oct 2007
    Location
    barnegat bay
    Posts
    434
    DEFINITE impeller replacement (may i recommend a solas 18/24) and a new housing wouldn't be such a bad idea. Take a look at it and make a judgement

  6. #6
    Brewster's Avatar
    Join Date
    Aug 2007
    Location
    Cape Cod, Ma.
    Posts
    317
    I would do both. You have 400 hours on it...if it's the original housing, it could be worn. If you do the work yourself, you can fit the new impeller in and measure the clearance between the housing and the impeller. Just get a shop manual to do this measurement correctly.

    Otherwise you could send your pump to Impros and have them go through your pump(bearings,stator vein, housing).

    Having the thing done professionally, will give you good performance and reliabilty. Just find a reputable shop or do it yourself.

    Just noticed you asked where to buy the parts. You can try Jerry's store first or check out Parkers performance, alot of Yamaha stuff pretty cheap and good service.
    Last edited by Brewster; 03-02-2008 at 10:10 PM.

  7. #7
    Thanks again...I called Impros this AM and will be sending them the entire unit to rebuild. For $300 it is not worth chancing it. Now...just have to figure out how to get the pump off without pulling the ride plate...

  8. #8
    Brewster's Avatar
    Join Date
    Aug 2007
    Location
    Cape Cod, Ma.
    Posts
    317
    You can remove the pump with the plate still on, but it's real tight. You might end up taking the plate off. The only problem is the speedo pick up, it's mounted to the plate with stainless phillips screws. There tough to get out and strip easily. You can heat them up but don't use a torch(damage to sensor), try a decent soldering gun and heat up the screw heads. They will start to deform on you, but eventually come free.


    You know, if your pulling the whole pump you might be alright. You have enough to grab onto and maybe break it free. Try it first before you resort to removing the ride plate.
    Last edited by Brewster; 03-03-2008 at 04:44 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. S/C question and Low RPM and Speed...Help!
    By joewharton2 in forum 4-Tec Performance
    Replies: 29
    Last Post: 11-20-2010, 07:19 AM
  2. bone stock rxp, rpm and speed question?
    By Brueskerxp06 in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-13-2007, 09:27 AM
  3. RPM vs. Speed question
    By big83bronco in forum Yamaha PWC Performance (2-stroke)
    Replies: 25
    Last Post: 08-04-2006, 08:06 AM
  4. 03 GTX with New S/C ... Still down on RPMs and Speed..?
    By Fast05RXP in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-21-2006, 02:12 PM
  5. rpm an speed question ???
    By Ty in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-19-2006, 04:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •