Results 1 to 7 of 7
  1. #1
    1996SLTX's Avatar
    Join Date
    May 2007
    Location
    Ft. Lauderdale, Florida
    Posts
    904
    +1
    1

    Skied today...first time in 3 months....

    The SLTX ran great! The weather was the only issue...78 degrees and really windy and the canal temp was cold. So it wasn't a very comfortable day but still felt good to get out there again.

    I did have a problem with water in the hull. It looks like my fiberglass repair started leaking water badly. Not sure why but water drips from it. At least I know my bilge pump kicks ass.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Glad to hear you're back out.
    Get er fixed and ride!!!

  3. #3
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    What did you use to patch the damage in the first place???

    Great to hear you got some skiing in, I'll be out on the water once this ice melts

  4. #4
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    78 and complaining!!! Today was the first day it hasn't snowed here all week.

  5. #5
    1996SLTX's Avatar
    Join Date
    May 2007
    Location
    Ft. Lauderdale, Florida
    Posts
    904
    +1
    1
    Quote Originally Posted by axgrider73 View Post
    78 and complaining!!! Today was the first day it hasn't snowed here all week.
    The day was totally beautiful, but the air was so dry that once the water spray hit you and you're going 40 mph, the evaporation off the skin was like being in an ice bath! I did everything I could to avoid getting wet but still try to have fun jumping my own wake.

    The wind was pushing 20 mph at times so the top end runs into the wind were brisk to say the least. We had the tube with us but I told the kids to forget about it. We've been battling a lung virus for a long time and a day like this being cold and wet wasn't in the cards.

  6. #6
    1996SLTX's Avatar
    Join Date
    May 2007
    Location
    Ft. Lauderdale, Florida
    Posts
    904
    +1
    1
    Quote Originally Posted by gorilla03 View Post
    What did you use to patch the damage in the first place???

    Great to hear you got some skiing in, I'll be out on the water once this ice melts
    I used 7 layers of a marine fiberglass kit. The original damage was about 15 inches long by 2 inches wide ride down the middle of the hull. All I did was lay the glass and hit it with primer. I'm no expert on this but for a few months I didn't have any trouble with it.

  7. #7
    Quote Originally Posted by axgrider73 View Post
    78 and complaining!!! Today was the first day it hasn't snowed here all week.
    You're telling me. The last time I rode the air temp was around 50 degrees.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 11-27-2010, 10:13 PM
  2. So... I had the ski out for the first time today...
    By GeordieBoyKel in forum Polaris Open Discussion
    Replies: 23
    Last Post: 01-26-2009, 03:00 PM
  3. Ultra LX first time in salt water
    By TBonesUltraLX in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 07-29-2008, 07:24 AM
  4. Replies: 0
    Last Post: 05-26-2008, 05:18 PM
  5. First time in the water (06 Sportster 215) ????
    By mstewart in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 09-04-2007, 07:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •