Results 1 to 3 of 3
  1. #1
    mavrick816's Avatar
    Join Date
    Oct 2007
    Location
    Sacramento, CA
    Posts
    138
    +1
    3

    05 GPR Oil Sensor

    I'm new to the GPR series. I have an 05 bone stock which I bought last year. It had 33 hours. I've riddent it for about 3 hours now. I rode for about an 1.5 hours today, the oil light sensor flashed, but no beep when I opened her up WOT for about 10 mins. I leveled her out and the light went away after a few mins, hit it hard again, but the light never came back. I've filled the ski with Yamalube when I first picked it up, it used up a whole gallon of oil.
    The ski runs great, idles great, GPSd at about 67. The engine compartment still smells new. Compression about 120 or 125. I've owned Sea-Doos but not familiar with Yamahas. So I'm still learning as I go.
    • My question is, is the oil sensor sensitive?
    • Do you think the last owner fudged the oil or engine?
    • Is this something I should worry about?
    • What else should I observe?
    • Should I take it in, if so what type of maintenance should be done to it?
    Thanks, I appreciate any help.
    -Rick


  2. #2
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Could be a bad sensor. There are 2 floats on the sensor in the oil tank. You can inspect the floats by pulling the whole sensor straight up and out of the tank. There is a long screen in there also.

  3. #3
    mavrick816's Avatar
    Join Date
    Oct 2007
    Location
    Sacramento, CA
    Posts
    138
    +1
    3
    Thanks, I'll take a look at it. Just wondering if this is a common occurence.

    Quote Originally Posted by WFO View Post
    Could be a bad sensor. There are 2 floats on the sensor in the oil tank. You can inspect the floats by pulling the whole sensor straight up and out of the tank. There is a long screen in there also.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 rxp knock sensor resistor
    By sandrock in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-28-2016, 01:11 AM
  2. 05 Gpr temp sensor #
    By Smokes in forum Yamaha PWC Performance (2-stroke)
    Replies: 52
    Last Post: 01-10-2013, 05:28 PM
  3. Oil sensor difference between 04/05 and 06+
    By Daz RXT in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-28-2011, 06:06 AM
  4. 05 Rxt oil sensor goes off at 4,000rpm.
    By ADAM12 in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-09-2008, 11:16 PM
  5. Oil injection pump 05 GPR
    By Josh B in forum Yamaha Classifieds
    Replies: 0
    Last Post: 06-12-2008, 06:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •