Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: polaris slh

  1. #1

    Exclamation polaris slh

    hello i am new here and i have a polaris slh 750 since last year and most of the days that i ride i gives me problems , after riding it for 30-40 minutes with no problems it starts to gag and seems like the gas is not geting to the engine i push why does it do that after working proporly for the first 30 minutes,i hope some one can help


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Welcome the the Hulk!

    What year is your SLH750?

    Sounds like fuel delivery issues.

    How long have you owned it?
    Have the carbs been disassembled and cleaned recently, or ever?

    Has the fuel system and gas tank been checked for debris, water contamination, clogged filters?

    Have the fuel lines ever been changed?

    Is everything original and stock?

    Has the engine been checked recently for general health?
    Cylinder compression, spark plug condition, piston wash, etc...

  3. #3
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Check your tank vents.

  4. #4
    Quote Originally Posted by K447 View Post
    Welcome the the Hulk!

    What year is your SLH750?

    Sounds like fuel delivery issues.

    How long have you owned it?
    Have the carbs been disassembled and cleaned recently, or ever?

    Has the fuel system and gas tank been checked for debris, water contamination, clogged filters?

    Have the fuel lines ever been changed?

    Is everything original and stock?

    Has the engine been checked recently for general health?
    Cylinder compression, spark plug condition, piston wash, etc...



    its from the year of 2001 and i own since last year and never dne none of does things

  5. #5
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    I agree with Tony, sounds like a bad fuel tank vent. When it starts acting up, crack the gas cap and see if that helps. Please note, if it is starving for fuel. you could cause engine damage if you continue to run it like this.

    It's always a good idea to go through the entire fuel system annually to insure that everything is in good working order.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by lubelio View Post
    It's from the year of 2001 and I own since last year and I have never done any of those things
    2001 SLH would be a domestic 700cc engine, not a Fuji 750 motor.

    The domestics don't have the same fuel line degradation worries that the older models did (750 engine).

    If opening the gas cap for a moment fixes the problem, then definitely check or replace the fuel tank venting valve.

    Much of the other stuff I mentioned could be considered maintenance items. Keep your boat in good condition, check what should be checked to keep it running well, and problems should be fewer and farther between.

  7. #7
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    while you're inspecting the tank vent, it wouldn't hurt to check all the fuel lines..

  8. #8
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    The 01 had those crappy grey lines that filled the carbs with smegma, CHECK those lines!!!
    Open the carbs and check the in-line filters.
    Pull the choke when it's falling on its face and let us know what happens.

  9. #9
    Quote Originally Posted by ph2ocraft View Post
    The 01 had those crappy grey lines that filled the carbs with smegma, CHECK those lines!!!
    Open the carbs and check the in-line filters.
    Pull the choke when it's falling on its face and let us know what happens.


    a iam also going to change the spark plugs ,could some one tell me witch are the beter ones to use.

  10. #10
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    My preference is NGK, be sure to use resistor type plugs as called for.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB 2000 polaris slh cdi
    By chritopherlloyd in forum Polaris Classifieds
    Replies: 1
    Last Post: 01-12-2009, 08:28 PM
  2. WTB: - - SEAT - - 2000 POLARIS SLH 700 Twin
    By MrRogue in forum Polaris Classifieds
    Replies: 3
    Last Post: 12-15-2008, 09:09 PM
  3. Seeking 98 99 00 Polaris SLH hull
    By kbsuffolk757 in forum Polaris Classifieds
    Replies: 1
    Last Post: 06-17-2008, 08:11 AM
  4. need help with polaris slh 700
    By holcomb21 in forum Polaris PWC Performance
    Replies: 7
    Last Post: 06-08-2008, 03:04 AM
  5. 98 Polaris SLH for sale w/trailer (NJ)
    By thedoc in forum Polaris Classifieds
    Replies: 7
    Last Post: 05-27-2008, 08:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •