Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    speed gear on ride plate

    just put new rideplate on but on the side of the pump where the little piece that has 4 bolts in it the speed gear hits that and i cant put it back on ride plate any suggestions


  2. #2
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    do you have a pic of the area? that will help figure out whats going on

  3. #3
    no pic the piece that screws on ride plate that calculates speed hits the pump and i cant line the holes up to screw the speed thing on

  4. #4
    Altezza01's Avatar
    Join Date
    Jun 2007
    Location
    Destin, FL
    Posts
    1,527
    +1
    13
    do you have a r&d ride plate? if you do you have to get a thinner plate to replace the stock plate on the side of the pump. a lot of members have spare plate you can buy from them. the piece you need is just the metal plate without the hole drilled in it. and shorter bolts as well

  5. #5
    my next mod is a holeshot kit will the plate that comes with that fix the problem and yes its a rd plate

  6. #6
    Altezza01's Avatar
    Join Date
    Jun 2007
    Location
    Destin, FL
    Posts
    1,527
    +1
    13
    r&d plates need that plate. and the holeshot kit will fix it. when you order a plate from r&d direct they should've sent you that plate. the speedo is probably hitting the bolt when you try to put it on huh?

  7. #7
    yes but i bought the plate new but from someone on form

  8. #8
    Altezza01's Avatar
    Join Date
    Jun 2007
    Location
    Destin, FL
    Posts
    1,527
    +1
    13
    yeah i got my plate used from a member. PM WFO and see if he has a spare plate you can buy. they shouldn't be that much. or just order the holeshot kit.

  9. #9
    cool ,thanks alot

  10. #10
    GPRider34's Avatar
    Join Date
    Nov 2007
    Location
    Grimesland, NC
    Posts
    50
    you can make the plate using urs as template for holes to drill

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What sandpaper should i use on ride plate?
    By mksmi in forum 4-Tec Performance
    Replies: 2
    Last Post: 12-10-2007, 07:51 PM
  2. Need opinions on ride plates
    By 1FASTXC in forum Polaris Open Discussion
    Replies: 20
    Last Post: 06-10-2007, 10:45 PM
  3. Stage I/Bolt Ons/Ride Plate Holes
    By JFizzleJR in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-14-2006, 11:15 PM
  4. Bolt On Ride Plate Extension
    By johnD in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-01-2006, 05:04 PM
  5. Questions on ride plates?
    By r33pwrd in forum Yamaha PWC Performance (2-stroke)
    Replies: 34
    Last Post: 03-27-2006, 10:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •