Results 1 to 6 of 6
  1. #1
    buzz
    Join Date
    Mar 2008
    Location
    durban south africa
    Posts
    27

    major blaster 1 problem please help

    i have been unable to ride my blaster 1 for five months now as after about a 20 min ride starts to not fire so good my thoughts are that there is water getting into my crank case or barrell, i have ruled out any electrical problem as i changed all the electrical parts. i have a blowsion head and riva pipe i have now stripped my whole engine to look for cracks or any place that water could be getting in but i am not finding anything, my crank berrings are now also starting to go witch i think confirms my thoughts that water is getting inside please can some one help me.


  2. #2
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    I believe you will find a lot more help at our Sister site on Blaster and Stand up platforms http://x-h2o.com/

  3. #3
    We have a sister site? is she hot?

  4. #4
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Quote Originally Posted by ZMANN View Post
    We have a sister site? is she hot?
    Yes and Yes

  5. #5
    Mongoose's Avatar
    Join Date
    Aug 2005
    Location
    Wales
    Posts
    665
    +1
    6
    Def a water leak.
    I had the same problem, and it turned out to be the exhaust manifold to barrel joint leaking.
    Worth looking there because, if my memory serves me right, even though the bolt holes lineup, some aftermarket manifolds work better with a 62t barrels, not the 61x.

  6. #6
    buzz
    Join Date
    Mar 2008
    Location
    durban south africa
    Posts
    27
    Quote Originally Posted by Mongoose View Post
    Def a water leak.
    I had the same problem, and it turned out to be the exhaust manifold to barrel joint leaking.
    Worth looking there because, if my memory serves me right, even though the bolt holes lineup, some aftermarket manifolds work better with a 62t barrels, not the 61x.
    well i presure tested it today and put it under water, i saw the smallest of bubble coming from the one exhaust manafold bolt but that goes to the exhaut water jacket so it could only leak out of the engine not into the barrell, i never new you got different barrels for a blaster 1
    Last edited by buzz; 03-06-2008 at 11:12 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. major blaster 1 problem please help
    By buzz in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 03-06-2008, 09:02 PM
  2. 2007 RXP Problem! Please Help
    By Ericc in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-11-2007, 10:33 AM
  3. 02 1200r Power Problem please help
    By team11haro in forum Yamaha Open Discussion
    Replies: 10
    Last Post: 03-23-2007, 02:05 PM
  4. Genesis FFI Oil Problem- Please help
    By jmason2088 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 11-08-2006, 01:36 PM
  5. '05 Rxp Problem Please Help
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2006, 03:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •