Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2008
    durban south africa

    major blaster 1 problem please help

    i have been unable to ride my blaster 1 for five months now as after about a 20 min ride starts to not fire so good my thoughts are that there is water getting into my crank case or barrell, i have ruled out any electrical problem as i changed all the electrical parts. i have a blowsion head and riva pipe i have now stripped my whole engine to look for cracks or any place that water could be getting in but i am not finding anything, my crank berrings are now also starting to go witch i think confirms my thoughts that water is getting inside please can some one help me.

  2. #2
    old school big raider's Avatar
    Join Date
    Sep 2006
    ck. the pipe for cracks

  3. #3
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    League City, Texas
    welcome to the forum buzz !

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. major blaster 1 problem please help
    By buzz in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 03-05-2008, 02:22 PM
  2. 2007 RXP Problem! Please Help
    By Ericc in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-11-2007, 10:33 AM
  3. 02 1200r Power Problem please help
    By team11haro in forum Yamaha Open Discussion
    Replies: 10
    Last Post: 03-23-2007, 02:05 PM
  4. Genesis FFI Oil Problem- Please help
    By jmason2088 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 11-08-2006, 01:36 PM
  5. '05 Rxp Problem Please Help
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2006, 03:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts