Results 1 to 5 of 5

Thread: '00 Virage

  1. #1

    Join Date
    Mar 2007
    Location
    West Fargo, ND
    Posts
    144

    '00 Virage

    I have a 2000 Virage that has a propulsion issue. I have removed the pump housing and look at the stator. The impeller looks good and I brought it to a Polaris dealer to verify, they also said it looked good. The stator, though, has a few chunks taken out of the viens, about the size of a nickle. The drive shaft ends are in good shape, no chewed up teeth.

    What the ski does is when you quickly apply power, it seems as though it is skipping or the shaft is slipping in the coupler. If you slowly apply power it will accellerate fine there is no sign of an issue.

    Is it my coupler bad or is it the stator?

    Thanks


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    It could be cavitation or the coupler. Reseal the ride plate and pump shoe. Check the coupler for signs of rubber powder or the smell of rubber.

  3. #3
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Yep,what Beers said,Let us know what you find out.

  4. #4

    Join Date
    Mar 2007
    Location
    West Fargo, ND
    Posts
    144
    It is -20 here and my ski's are in a snow bank. This will be the first thing I check once the ice is out.

    Thanks

  5. #5
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Have a little heat spell are you?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How do you remove the exhaust pipe on a 00 Virage?
    By chvscks319 in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 07-24-2009, 10:58 AM
  2. will upgade kit parts work on 00 virage 700
    By jtb5351 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-02-2009, 09:55 PM
  3. Anybody from here bidding on this 00 Virage TX?
    By PolarisNut in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-07-2008, 09:59 PM
  4. 00 Virage 700 Cylinder Question
    By jetworx hawaii in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-16-2007, 07:10 PM
  5. 00 Virage 700 Cylinder Question
    By jetworx hawaii in forum Polaris Projects
    Replies: 1
    Last Post: 08-16-2007, 07:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •