Results 1 to 4 of 4
  1. #1

    Grinding noise left hand turns

    My first post so be gentle.

    My 2007 Ultra has developed a grinding noise when turning left under load. The noise is more significant when the ski warms up after about 1/2 hour of riding. There is no noise or vibration in straight line or Right Hand turns. There is now 37 hours on the ski & the noise is getting worse everytime I take it out.

    Any ideas?

  2. #2
    Silence! I Keel You! earthshaker's Avatar
    Join Date
    May 2007
    Northern CA Coast
    Welcome to Greenhulk. First thing that comes to mind is loose pump or motor mounts.

  3. #3
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Old Hickory,Tn
    Impeller loose?

  4. #4
    Thanks guys great advice, it will give me a direction to start with. I was just wondering if anyone else has experienced this problem?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ski died in left hand hand turn...twice???
    By grantuk in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-07-2008, 10:16 AM
  2. Hard left hand turn problem. Engine dies out.
    By fussy1 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 10-15-2007, 10:06 PM
  3. Extremely rough engine yesterday- grinding noise
    By vidbuster in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-26-2007, 11:26 AM
  4. Help diagnosing a grinding noise? Z
    By ZMANN in forum Polaris Open Discussion
    Replies: 12
    Last Post: 10-10-2006, 11:02 PM
  5. no drive and bad grinding noise
    By timbo in forum 4-Tec Performance
    Replies: 19
    Last Post: 01-27-2006, 10:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts