Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198

    Leaking A-freeze on the ride plate

    I just noticed Anti Freeze leaking from 2 screws & it looks like the plastic washers are peeling off. Do I need the plastic POS's or can I use SS washers?


  2. #2
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    I had the same problem. Pull the pump and give them a good torque down.

    Brendan

  3. #3

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    Quote Originally Posted by BDNJ View Post
    I had the same problem. Pull the pump and give them a good torque down.

    Brendan


    NO-O Do not torque them down....Yet. Remove the screws and put Black silicone around the screw and then...

  4. #4
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Quote Originally Posted by BDNJ View Post
    I had the same problem. Pull the pump and give them a good torque down.

    Brendan

    Thanx

  5. #5
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Quote Originally Posted by jawz View Post
    NO-O Do not torque them down....Yet. Remove the screws and put Black silicone around the screw and then...

    Thanx to you too..

  6. #6
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169
    I know this is an old thread, but while checking my pump for my porposing problem on the RXP I noticed two screws leaking anti freeze. One has a little around the screw, the other has a small dribble. Must not be too bad since I have never noticed any less in the over flow tank. Take the screw out and use silicone? Replace the crappy rubber washer too? Is there a torque spec for them?

  7. #7
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Quote Originally Posted by antoniodef View Post
    I know this is an old thread, but while checking my pump for my porposing problem on the RXP I noticed two screws leaking anti freeze. One has a little around the screw, the other has a small dribble. Must not be too bad since I have never noticed any less in the over flow tank. Take the screw out and use silicone? Replace the crappy rubber washer too? Is there a torque spec for them?
    Remove the plastic washer & use "right stuff" & torque it snug but not white knuckle tight....
    I don't know the torque spec...

  8. #8
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169
    I looked in the service manual I have, but didn't see anything...does anyone know what you torque the bolts too? It is the ones you have to pull the pump to get too.

  9. #9
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    hand tight w/ right-stuff no torque wrench for me. let sit for a day and have had no problems at all. the plate is aluminum so you can't put tooooo much torque on it anyways

  10. #10
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169
    So I pulled my pump off after work tonight. One of the bolts leaking is way in the back where you can't fit a wrench or anything. I'll take a pic of it tomorrow.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Quick Question!, What is this screw on the ride plate?
    By Yanksfan in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 01-23-2013, 04:09 PM
  2. Is this gap normal on the ride plate?
    By xray328 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 11-13-2011, 03:07 AM
  3. How bad is pitting on the ride plate, need repairing?
    By aquaaddict in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-25-2011, 08:24 PM
  4. gp1300r water leaking by two bolt on the ride plate
    By mike1706 in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 01-03-2010, 07:23 PM
  5. Replies: 1
    Last Post: 05-18-2008, 10:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •