Results 1 to 9 of 9
  1. #1
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    647
    +1
    28

    Exclamation Power Valve Shaft #1, 01'GP1200R

    OOPPSS!!!
    Took out my power valves today to get carbon deposits off they all look good. Those E-clips are a pain...Anyway, i pulled out all the shafts and when I went to reinstall all was well except for shaft #1 (closest to front of ski) it is unround. I believe do to my own fault. I ordered another one from RIVA should be hear early next week.
    Should I replace all the oil seals as well?? And what is the best way to do this install?? I did a search and cannot find anything worth while..Please guys help me out..Do I lube up oil seals when putting new ones in, can I get shaft #1 in from the front of the boat so I do not have to shove and torque it through all three power valves?? I believe that is how I messed it up in the first place...HELP!!!!!


  2. #2
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    just read the manual has everything in there
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	powervalve page 1.jpg 
Views:	103 
Size:	67.0 KB 
ID:	61391   Click image for larger version. 

Name:	powervalve page 2.jpg 
Views:	65 
Size:	60.3 KB 
ID:	61392   Click image for larger version. 

Name:	powervalve page 3.jpg 
Views:	70 
Size:	63.2 KB 
ID:	61393   Click image for larger version. 

Name:	powervalve page 4.jpg 
Views:	69 
Size:	57.9 KB 
ID:	61394  

  3. #3
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    647
    +1
    28
    I have the manual, but what I want to learn is what they do not show you in the manual. Has anyone ever had a bent shaft or had a very hard time getting the shafts back in and rotating smoothly??

  4. #4
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    647
    +1
    28
    Yes I am being serious, after reading my last post i was sure someone would chime in and give me some @#$T !!!
    But am serious need help what should I do...
    Last edited by Ramps; 03-08-2008 at 09:45 PM. Reason: Grammar

  5. #5
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Yes I would use new seals.
    Yes Lube them.
    I would install the #1 seals then the #1 shaft then, #2 seals and shaft, this will allow you to slide #1 all the way with no restrictions.

    I have never done one in the ski but from your posts now see the challenges that arise.

    I wish you would have posted you needed a shaft I think I have a few in the garage and would have been happy to send you one.

  6. #6
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    647
    +1
    28
    I did not even think of that. Thanks OsideBill. I will order the seals tonight. This forum has really helped me out and has let me build a fast reliable ski.

    P.S. Next time I will post a WTB before I go to RIVA....

  7. #7
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Quote Originally Posted by Ramps View Post
    I did not even think of that. Thanks OsideBill. I will order the seals tonight. This forum has really helped me out and has let me build a fast reliable ski.

    P.S. Next time I will post a WTB before I go to RIVA....
    If and when you need to go through Riva go through the store here and get a 10% discount if you don't see the riva item you want listed send Jerry (Green hulk) a pm and he will take care of you.

  8. #8
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    647
    +1
    28
    Will do, thanks for the advice...

  9. #9
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    647
    +1
    28
    Do you know of a good way to get the seals in properly? Is their a tool I should be using to press them in?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB Power Valve Motor for GP1200r 01
    By chris1200 in forum Yamaha Classifieds
    Replies: 1
    Last Post: 06-05-2009, 04:39 PM
  2. HELP-----exh. valve shaft trouble !!!!!! gp1200r
    By KEYZBUM in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 01-12-2009, 04:05 PM
  3. wtd intermediate shaft for 01 gp1200r
    By jetski1200r in forum Yamaha Classifieds
    Replies: 1
    Last Post: 08-30-2008, 04:54 PM
  4. quick power valve question..gp1200r 2000
    By Hydrotherapy in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 07-28-2007, 02:21 AM
  5. power valves twitching ? GP1200R
    By riva bill in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 11-08-2006, 03:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •