Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1

    Join Date
    Mar 2008
    Location
    Fayetteville, NC
    Posts
    38

    sl 750 need help

    I just inhereted a (94 or 95) SL 750 from my lil borther and its wont start. Since I am new to this, where should I begin my repairs? Should I take it in to a shop or what? Can repairing be somthing that I can do? I am some what mechanichaly inclined so I am not affraid to dive right in, I just want to make sure that I am not doing more damage than good. Also are is there a good place on the net tha I can find parts for this model? I would appreciate any info on this....


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Welcome to the hulk.
    You came to the right place..
    First check compression and let us know what you find.
    Manual can be found here. http://www.mattmans.com/polaris/upload

  3. #3
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    WELCOME TO THE HULK
    BEST PLACE FOR PEOPLE AND INFO might find some parts laying around 2!!!!
    these guys will teach you and me at the same time
    have fun and again WELCOME
    MATTMAN

  4. #4
    Water Bum Rodneyae's Avatar
    Join Date
    Dec 2006
    Location
    Roanoke, Va
    Posts
    3,083
    Welcome to the HULK!!!!!!!! You need to check compression, fuel, spark. If you have all three then it should run, unless crank is out of index..... I would start out checking compression. If good, then check for fuel getting into the engine. If good then check for spark. Let us know what you find. The people here at the Hulk are some of the BEST!!!!!!

  5. #5

    Join Date
    Mar 2008
    Location
    Fayetteville, NC
    Posts
    38
    Thanks for the info, ill get on it asap. I will post my results. I plan on getting some of the tools tomorrow...

  6. #6
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    WELCOME to the Green Hulk Forums!!!

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Welcome to the Hulk. Can you elaborate on the no start when asking questions? Does it crank over? Are you getting fuel? Is there spark present? etc.... We need as much info as possible to help guide you in the right direction.

  8. #8

    Join Date
    Mar 2008
    Location
    Fayetteville, NC
    Posts
    38
    the ski will crank over, it was sititng around for 4 months since last use, it seems to be getting fuel as far as I can tell, i check the fuel water separator for water, that is about the extend of my brief overview. My plans to get a compression tester and get those posted asap. I was given three diferrent batteries I will charge them up and test them.

    My lil bro said that he thinks he might have gotten water in the engine , but not sure....

    Its stressful because I have called around the area that i live in and there is no service center that will look at a polaris.....

  9. #9
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Make sure you have a fully charged battery when trying to start it. If the batt will not supply 10.5 volts while cranking, it will not fire.

  10. #10

    Join Date
    Mar 2008
    Location
    Fayetteville, NC
    Posts
    38
    Well, I charged the batteries, they do look a lil beat up, I plan on getting a new one ( any recomendation?); the voltate according to the tester/charger (12.5); I also tested the compression and took some photos here is what I got:

    Cyl #1 - 131 psi
    Cyl #2 - 128 psi
    Cyl #3 - 130 psi

    According to the manual they seem with in tolerance of 5% from each other and with in compression range of 120-150.

    I do need to replace the water separator bracket that is broken, (where can i order one from?)

    What should I try next?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris sl 750 need help
    By polaris on fire in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-12-2014, 07:17 PM
  2. Replies: 2
    Last Post: 08-22-2011, 11:35 AM
  3. 95 sl 750 need help
    By dooman in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-08-2011, 12:25 PM
  4. 93' and 94' SL 750 need help!!
    By dubstylguy in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-22-2008, 01:30 PM
  5. 1996 Polaris SL 700 (NEED HELP!!!!)
    By Alberta Boy in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-08-2007, 10:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •